* add outfunction to MSGS that just outputs ID|EUID
[citadel.git] / citadel / debian / rules
index 95d0aa2e86e78193bdf25549d9d700ca9167d4ee..c9b87e558f686c3a01ccc02902daa85f5bdaf342 100755 (executable)
@@ -25,6 +25,7 @@ ifneq (,$(findstring debug,$(DEB_BUILD_OPTIONS)))
        LDFLAGS+=-Wl,--no-undefined -Wl,--as-needed
        EXTRA_ARGS = --with-backtrace
 else
+       LDFLAGS+=-Wl,--no-undefined -Wl,--as-needed
        CFLAGS += -O2
 endif
 
@@ -38,22 +39,20 @@ configure: configure-stamp
 configure-stamp:
        dh_testdir
 
-       CFLAGS="$(CFLAGS)" ./configure \
-               --with-prefix=/var/lib/citadel \
-               --with-datadir=/var/lib/citadel \
-               --with-staticdatadir=/usr/share/citadel-server \
-               --with-spooldir=/var/spool/citadel \
-               --with-sysconfdir=/etc/citadel \
-               --with-rundir=/var/run/citadel \
+       LDFLAGS="$(LDFLAGS)"; CFLAGS="$(CFLAGS)" ./configure \
+               --prefix=/var/lib/citadel/ \
+               --with-datadir=/var/lib/citadel/ \
+               --with-helpdir=/usr/share/citadel-server/ \
+               --with-staticdatadir=/etc/citadel/ \
+               --with-spooldir=/var/spool/citadel/ \
+               --with-sysconfdir=/etc/citadel/ \
+               --with-rundir=/var/run/citadel/ \
                --with-docdir=/usr/share/doc/citadel-doc/ \
                --with-ssldir=/etc/ssl/citadel/ \
                --with-utility-bindir=/usr/lib/citadel-server/ \
+               --with-autosysconfdir=/var/lib/citadel/data/ \
                --with-pam \
                --with-db \
-               --with-zlib \
-               --with-ldap \
-               --with-libical \
-               --with-libsieve \
                --enable-debug $(EXTRA_ARGS) $(PROFILE_ARGS) $(THREAD_ARGS)
 
        touch configure-stamp
@@ -83,7 +82,7 @@ clean:
        rm -f config.status config.log
 
 install: install-indep install-arch
-install-indep:
+install-indep: build-indep
        dh_testdir
        dh_testroot
        dh_clean -k -i 
@@ -93,7 +92,7 @@ install-indep:
 
        dh_install -i --sourcedir=debian/tmp
 
-install-arch:
+install-arch: build-arch
        dh_testdir
        dh_testroot
        dh_clean -k -s 
@@ -120,7 +119,8 @@ binary-common:
        dh_installdebconf       
        dh_installinit --name=citadel
        dh_installman
-       dh_strip
+       dh_strip --dbg-package=citadel-dbg
+       dh_link
        dh_compress 
        dh_fixperms
        dh_makeshlibs