]> code.citadel.org Git - citadel.git/blobdiff - citadel/debian/rules
* add outfunction to MSGS that just outputs ID|EUID
[citadel.git] / citadel / debian / rules
index fef1a8bf64bad9fa1b826c56e1602220305e944a..c9b87e558f686c3a01ccc02902daa85f5bdaf342 100755 (executable)
@@ -4,38 +4,56 @@
 #export DH_VERBOSE=1
 
 # This has to be exported to make some magic below work.
+DEB_HOST_GNU_TYPE   ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
+DEB_BUILD_GNU_TYPE  ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
+
 export DH_OPTIONS
 
 DEB_DESTDIR = $(CURDIR)/debian/tmp
 
 CFLAGS = -Wall -g
 
-#ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
-       CFLAGS += -O0 -ggdb -pg
-#else
-#      CFLAGS += -O2
-#endif
+
+EXTRA_ARGS=
+PROFILE_ARGS=
+#to enable debugging: export DEB_BUILD_OPTIONS="debug profiling threadoff"
+ifneq (,$(findstring profiling,$(DEB_BUILD_OPTIONS)))
+       PROFILE_ARGS= --with-gprof
+endif
+ifneq (,$(findstring debug,$(DEB_BUILD_OPTIONS)))
+       CFLAGS += -O0 -ggdb -rdynamic -D_GNU_SOURCE -MD -MP -D TECH_PREVIEW
+       LDFLAGS+=-Wl,--no-undefined -Wl,--as-needed
+       EXTRA_ARGS = --with-backtrace
+else
+       LDFLAGS+=-Wl,--no-undefined -Wl,--as-needed
+       CFLAGS += -O2
+endif
+
+ifneq (,$(findstring threadoff,$(DEB_BUILD_OPTIONS)))
+       THREAD_ARGS=--without-threaded-client
+else
+       THREAD_ARGS=
+endif
 
 configure: configure-stamp
 configure-stamp:
        dh_testdir
 
-       CFLAGS="$(CFLAGS)" ./configure \
-               --with-prefix=/var/lib/citadel \
-               --with-datadir=/var/lib/citadel \
-               --with-staticdatadir=/usr/share/citadel-server \
-               --with-spooldir=/var/spool/citadel \
-               --with-sysconfdir=/etc/citadel \
-               --with-rundir=/var/run/citadel \
+       LDFLAGS="$(LDFLAGS)"; CFLAGS="$(CFLAGS)" ./configure \
+               --prefix=/var/lib/citadel/ \
+               --with-datadir=/var/lib/citadel/ \
+               --with-helpdir=/usr/share/citadel-server/ \
+               --with-staticdatadir=/etc/citadel/ \
+               --with-spooldir=/var/spool/citadel/ \
+               --with-sysconfdir=/etc/citadel/ \
+               --with-rundir=/var/run/citadel/ \
                --with-docdir=/usr/share/doc/citadel-doc/ \
                --with-ssldir=/etc/ssl/citadel/ \
                --with-utility-bindir=/usr/lib/citadel-server/ \
+               --with-autosysconfdir=/var/lib/citadel/data/ \
                --with-pam \
                --with-db \
-               --with-zlib \
-               --with-ldap \
-               --with-libical \
-               --with-libsieve
+               --enable-debug $(EXTRA_ARGS) $(PROFILE_ARGS) $(THREAD_ARGS)
 
        touch configure-stamp
 
@@ -58,13 +76,13 @@ clean:
        dh_testroot
        rm -f build-arch-stamp build-indep-stamp configure-stamp
 
-       -$(MAKE) distclean
+       [ ! -f Makefile ] || $(MAKE) distclean
 
        dh_clean 
        rm -f config.status config.log
 
 install: install-indep install-arch
-install-indep:
+install-indep: build-indep
        dh_testdir
        dh_testroot
        dh_clean -k -i 
@@ -74,7 +92,7 @@ install-indep:
 
        dh_install -i --sourcedir=debian/tmp
 
-install-arch:
+install-arch: build-arch
        dh_testdir
        dh_testroot
        dh_clean -k -s 
@@ -101,7 +119,8 @@ binary-common:
        dh_installdebconf       
        dh_installinit --name=citadel
        dh_installman
-       dh_strip
+       dh_strip --dbg-package=citadel-dbg
+       dh_link
        dh_compress 
        dh_fixperms
        dh_makeshlibs