FDIOBuffer: wrong member type; thus we need increase the library version again.
[citadel.git] / libcitadel / configure.in
index 0d21b1121d2f8317a90376acb0a4f078104d5234..1e1ffb2634958c3b55a59b9ef92ec242faeeeae7 100755 (executable)
@@ -5,7 +5,7 @@ dnl
 dnl Ensure that libcitadel is configured with autoconf 2.52 or newer
 AC_PREREQ(2.52)
 
-AC_INIT(libcitadel, 2.8.13, http://uncensored.citadel.org)
+AC_INIT(libcitadel, 4.8.19, http://uncensored.citadel.org)
 
 AC_CONFIG_SRCDIR(Makefile.in)
 AC_CONFIG_AUX_DIR(conftools)
@@ -22,8 +22,8 @@ dnl
 dnl If the API changes incompatibly set LIBAGE back to 0
 dnl
 
-LIBCURRENT=2
-LIBREVISION=813
+LIBCURRENT=4
+LIBREVISION=819
 LIBAGE=0
 
 sinclude(conftools/libtool.m4)
@@ -103,6 +103,36 @@ AC_TRY_COMPILE([
                ]
 )
 
+AC_MSG_CHECKING([whether your system likes memcpy + HKEY]) 
+AC_TRY_COMPILE([
+#define _GNU_SOURCE
+#include <ctype.h>
+#include <errno.h>
+#include <string.h>
+#include <unistd.h>
+#include <string.h>
+#include <stdio.h>
+#include <sys/select.h>
+#include <fcntl.h>
+#include <sys/types.h>
+
+#include "lib/libcitadel.h"
+],
+[
+       char foo[22];
+       memcpy(foo, HKEY("foo"));
+       
+],
+               [
+
+                 AC_MSG_RESULT([yes])
+               ],
+               [ 
+                 AC_DEFINE(UNDEF_MEMCPY, [], [whether we need to undefine memcpy])
+                 AC_MSG_RESULT([no])
+               ]
+)
+
 
 AC_CHECK_HEADERS(iconv.h)