Version number set to 8.10 across the whole code base
[citadel.git] / libcitadel / configure.in
index b22ca13abab44871c8585e11ef9131b56b1bd5ad..3a6e803b295e51c262cfe356c793c43afa22624a 100755 (executable)
@@ -5,7 +5,7 @@ dnl
 dnl Ensure that libcitadel is configured with autoconf 2.52 or newer
 AC_PREREQ(2.52)
 
-AC_INIT(libcitadel, 7.70, https://uncensored.citadel.org)
+AC_INIT(libcitadel, 8.10, http://uncensored.citadel.org)
 
 AC_CONFIG_SRCDIR(Makefile.in)
 AC_CONFIG_AUX_DIR(conftools)
@@ -23,8 +23,8 @@ dnl If the API changes incompatibly set LIBAGE back to 0
 dnl
 
 LIBCURRENT=2
-LIBREVISION=0
-LIBAGE=0
+LIBREVISION=2
+LIBAGE=1
 
 sinclude(conftools/libtool.m4)
 sinclude(conftools/ac_c_bigendian_cross.m4)
@@ -74,6 +74,8 @@ fi
 
 AC_CHECK_HEADER(CUnit/CUnit.h, [AC_DEFINE(ENABLE_TESTS, [], [whether we should compile the test-suite])])
 
+AC_CHECK_HEADER(sys/sendfile.h, [AC_DEFINE(LINUX_SENDFILE, [], [whether we have the linux sendfile api])])
+dnl TODO: we might need to check for the actual syntax....  
 
 
 AC_CHECK_HEADERS(iconv.h)