Version number set to 8.10 across the whole code base
[citadel.git] / libcitadel / configure.in
index b70532b8ef22c9f426226f772fdafd698fe86e9d..3a6e803b295e51c262cfe356c793c43afa22624a 100755 (executable)
@@ -5,11 +5,11 @@ dnl
 dnl Ensure that libcitadel is configured with autoconf 2.52 or newer
 AC_PREREQ(2.52)
 
-AC_INIT(libcitadel, 7.38, https://uncensored.citadel.org)
+AC_INIT(libcitadel, 8.10, http://uncensored.citadel.org)
 
 AC_CONFIG_SRCDIR(Makefile.in)
 AC_CONFIG_AUX_DIR(conftools)
-
+AC_CONFIG_SRCDIR(tests/Makefile.in)
 
 dnl
 dnl Increment LIBREVISION if source code has changed at all
@@ -22,9 +22,9 @@ dnl
 dnl If the API changes incompatibly set LIBAGE back to 0
 dnl
 
-LIBCURRENT=1
-LIBREVISION=0
-LIBAGE=0
+LIBCURRENT=2
+LIBREVISION=2
+LIBAGE=1
 
 sinclude(conftools/libtool.m4)
 sinclude(conftools/ac_c_bigendian_cross.m4)
@@ -72,6 +72,12 @@ if test "x$ok_zlib" = xyes ; then
         AC_DEFINE(HAVE_ZLIB,[],[whether we have zlib])
 fi
 
+AC_CHECK_HEADER(CUnit/CUnit.h, [AC_DEFINE(ENABLE_TESTS, [], [whether we should compile the test-suite])])
+
+AC_CHECK_HEADER(sys/sendfile.h, [AC_DEFINE(LINUX_SENDFILE, [], [whether we have the linux sendfile api])])
+dnl TODO: we might need to check for the actual syntax....  
+
+
 AC_CHECK_HEADERS(iconv.h)
 
 
@@ -131,6 +137,17 @@ else
        AC_MSG_RESULT(libcitadel will be built without character set conversion.)
 fi
 
+dnl disable backtrace if we don't want it.
+AC_ARG_WITH(backtrace, 
+                   [  --with-backtrace          enable backtrace dumps in the syslog],
+                       [ if test "x$withval" != "xno" ; then
+                            CFLAGS="$CFLAGS  -rdynamic "
+                            LDFLAGS="$LDFLAGS  -rdynamic "
+                             AC_CHECK_FUNCS(backtrace)
+                         fi
+                       ]
+)
+
 
 AC_ARG_WITH(with_zlib,    [  --with-zlib             use zlib compression if present])
 dnl Checks for the zlib compression library.
@@ -149,11 +166,12 @@ fi
 
 dnl Checks for typedefs, structures, and compiler characteristics.
 
+AC_SUBST(LIBS)
 AC_C_CONST
 AC_TYPE_SIZE_T
 AC_CHECK_FUNCS(memmove bcopy)
 
-AC_CONFIG_FILES(Makefile libcitadel.pc)
+AC_CONFIG_FILES(Makefile libcitadel.pc tests/Makefile)
 AC_CONFIG_HEADER(sysdep.h)
 AC_OUTPUT