changing internal version number to 8.12
[citadel.git] / libcitadel / configure.in
index 7ddad84e1e144aaf04e5bc43c63046318d1def87..89b6aeea2d85fb90f6b1fa7606f91d22b118d6be 100755 (executable)
@@ -5,11 +5,11 @@ dnl
 dnl Ensure that libcitadel is configured with autoconf 2.52 or newer
 AC_PREREQ(2.52)
 
-AC_INIT(libcitadel, 7.50, https://uncensored.citadel.org)
+AC_INIT(libcitadel, 2.8.12, http://uncensored.citadel.org)
 
 AC_CONFIG_SRCDIR(Makefile.in)
 AC_CONFIG_AUX_DIR(conftools)
-
+AC_CONFIG_SRCDIR(tests/Makefile.in)
 
 dnl
 dnl Increment LIBREVISION if source code has changed at all
@@ -23,7 +23,7 @@ dnl If the API changes incompatibly set LIBAGE back to 0
 dnl
 
 LIBCURRENT=2
-LIBREVISION=0
+LIBREVISION=812
 LIBAGE=0
 
 sinclude(conftools/libtool.m4)
@@ -72,6 +72,38 @@ if test "x$ok_zlib" = xyes ; then
         AC_DEFINE(HAVE_ZLIB,[],[whether we have zlib])
 fi
 
+AC_CHECK_HEADER(CUnit/CUnit.h, [AC_DEFINE(ENABLE_TESTS, [], [whether we should compile the test-suite])])
+
+AC_CHECK_HEADER(sys/sendfile.h, [AC_DEFINE(LINUX_SENDFILE, [], [whether we have the linux sendfile api])])
+dnl TODO: we might need to check for the actual syntax....  
+
+
+AC_MSG_CHECKING([whether your system knows about splice()]) 
+AC_TRY_COMPILE([
+#define _GNU_SOURCE
+#include <unistd.h>
+#include <fcntl.h>
+],
+[
+       ssize_t sent, pipesize;
+       int fd, SplicePipe[2];
+       pipesize = splice(fd, NULL, 
+                         SplicePipe[1], NULL, 
+                         1, 
+                         SPLICE_F_MORE | SPLICE_F_MOVE|SPLICE_F_NONBLOCK);
+],
+               [
+                 ok_splice=yes
+                 AC_DEFINE(LINUX_SPLICE, [], [whether we have the linux splice api])
+                 AC_MSG_RESULT([yes])
+               ],
+               [ 
+                 ok_splice=no
+                 AC_MSG_RESULT([no])
+               ]
+)
+
+
 AC_CHECK_HEADERS(iconv.h)
 
 
@@ -165,7 +197,7 @@ AC_C_CONST
 AC_TYPE_SIZE_T
 AC_CHECK_FUNCS(memmove bcopy)
 
-AC_CONFIG_FILES(Makefile libcitadel.pc)
+AC_CONFIG_FILES(Makefile libcitadel.pc tests/Makefile)
 AC_CONFIG_HEADER(sysdep.h)
 AC_OUTPUT