* apply the release stuff to head too from r8127
[citadel.git] / libcitadel / configure.in
index 8d8e27490e9436858f5015e8086fc09399ee6fda..b22ca13abab44871c8585e11ef9131b56b1bd5ad 100755 (executable)
@@ -5,11 +5,11 @@ dnl
 dnl Ensure that libcitadel is configured with autoconf 2.52 or newer
 AC_PREREQ(2.52)
 
-AC_INIT(libcitadel, 7.38, https://uncensored.citadel.org)
+AC_INIT(libcitadel, 7.70, https://uncensored.citadel.org)
 
 AC_CONFIG_SRCDIR(Makefile.in)
 AC_CONFIG_AUX_DIR(conftools)
-
+AC_CONFIG_SRCDIR(tests/Makefile.in)
 
 dnl
 dnl Increment LIBREVISION if source code has changed at all
@@ -22,7 +22,7 @@ dnl
 dnl If the API changes incompatibly set LIBAGE back to 0
 dnl
 
-LIBCURRENT=1
+LIBCURRENT=2
 LIBREVISION=0
 LIBAGE=0
 
@@ -72,6 +72,10 @@ if test "x$ok_zlib" = xyes ; then
         AC_DEFINE(HAVE_ZLIB,[],[whether we have zlib])
 fi
 
+AC_CHECK_HEADER(CUnit/CUnit.h, [AC_DEFINE(ENABLE_TESTS, [], [whether we should compile the test-suite])])
+
+
+
 AC_CHECK_HEADERS(iconv.h)
 
 
@@ -131,6 +135,17 @@ else
        AC_MSG_RESULT(libcitadel will be built without character set conversion.)
 fi
 
+dnl disable backtrace if we don't want it.
+AC_ARG_WITH(backtrace, 
+                   [  --with-backtrace          enable backtrace dumps in the syslog],
+                       [ if test "x$withval" != "xno" ; then
+                            CFLAGS="$CFLAGS  -rdynamic "
+                            LDFLAGS="$LDFLAGS  -rdynamic "
+                             AC_CHECK_FUNCS(backtrace)
+                         fi
+                       ]
+)
+
 
 AC_ARG_WITH(with_zlib,    [  --with-zlib             use zlib compression if present])
 dnl Checks for the zlib compression library.
@@ -154,7 +169,7 @@ AC_C_CONST
 AC_TYPE_SIZE_T
 AC_CHECK_FUNCS(memmove bcopy)
 
-AC_CONFIG_FILES(Makefile libcitadel.pc)
+AC_CONFIG_FILES(Makefile libcitadel.pc tests/Makefile)
 AC_CONFIG_HEADER(sysdep.h)
 AC_OUTPUT