* anounce mmap to xdgmime.
[citadel.git] / libcitadel / configure.in
index 73f2193d8bd2710911392cedbb5241bbc4071abb..c2cee8536db430a6696f6635a8d885063e9c45dd 100755 (executable)
@@ -5,7 +5,7 @@ dnl
 dnl Ensure that libcitadel is configured with autoconf 2.52 or newer
 AC_PREREQ(2.52)
 
-AC_INIT(citadel, 1.00, example@example.com)
+AC_INIT(libcitadel, 1.03, https://uncensored.citadel.org)
 
 AC_CONFIG_SRCDIR(Makefile.in)
 AC_CONFIG_AUX_DIR(conftools)
@@ -57,6 +57,9 @@ fi
 dnl Checks for header files.
 AC_HEADER_STDC
 
+AC_CHECK_HEADER(sys/mman.h, [CFLAGS="$CFLAGS -D HAVE_MMAP"])
+
+
 dnl Checks for typedefs, structures, and compiler characteristics.
 
 AC_C_CONST