push tags
[citadel.git] / libcitadel / configure.in
index fb45b74a2068e8c7cf02ef82f8a3de93b012c8a2..c58b37714ff5c1d8bd6599587f32327b79475127 100755 (executable)
@@ -5,7 +5,7 @@ dnl
 dnl Ensure that libcitadel is configured with autoconf 2.52 or newer
 AC_PREREQ(2.52)
 
-AC_INIT(libcitadel, 3.8.13, http://uncensored.citadel.org)
+AC_INIT(libcitadel, 4.8.23, http://uncensored.citadel.org)
 
 AC_CONFIG_SRCDIR(Makefile.in)
 AC_CONFIG_AUX_DIR(conftools)
@@ -22,8 +22,8 @@ dnl
 dnl If the API changes incompatibly set LIBAGE back to 0
 dnl
 
-LIBCURRENT=3
-LIBREVISION=813
+LIBCURRENT=4
+LIBREVISION=823
 LIBAGE=0
 
 sinclude(conftools/libtool.m4)
@@ -103,6 +103,36 @@ AC_TRY_COMPILE([
                ]
 )
 
+AC_MSG_CHECKING([whether your system likes memcpy + HKEY]) 
+AC_TRY_COMPILE([
+#define _GNU_SOURCE
+#include <ctype.h>
+#include <errno.h>
+#include <string.h>
+#include <unistd.h>
+#include <string.h>
+#include <stdio.h>
+#include <sys/select.h>
+#include <fcntl.h>
+#include <sys/types.h>
+
+#include "lib/libcitadel.h"
+],
+[
+       char foo[22];
+       memcpy(foo, HKEY("foo"));
+       
+],
+               [
+
+                 AC_MSG_RESULT([yes])
+               ],
+               [ 
+                 AC_DEFINE(UNDEF_MEMCPY, [], [whether we need to undefine memcpy])
+                 AC_MSG_RESULT([no])
+               ]
+)
+
 
 AC_CHECK_HEADERS(iconv.h)