Add support for sending / reading to files; so far we just implement the linux sendfi...
[citadel.git] / libcitadel / configure.in
index 90b057e2c3253bab6681d284ca2d138554c587e7..d61a071c30f964bb94d233e542b727e83c9beb64 100755 (executable)
@@ -5,7 +5,7 @@ dnl
 dnl Ensure that libcitadel is configured with autoconf 2.52 or newer
 AC_PREREQ(2.52)
 
-AC_INIT(libcitadel, 7.63, https://uncensored.citadel.org)
+AC_INIT(libcitadel, 8.00, http://uncensored.citadel.org)
 
 AC_CONFIG_SRCDIR(Makefile.in)
 AC_CONFIG_AUX_DIR(conftools)
@@ -23,7 +23,7 @@ dnl If the API changes incompatibly set LIBAGE back to 0
 dnl
 
 LIBCURRENT=2
-LIBREVISION=0
+LIBREVISION=1
 LIBAGE=0
 
 sinclude(conftools/libtool.m4)
@@ -74,6 +74,8 @@ fi
 
 AC_CHECK_HEADER(CUnit/CUnit.h, [AC_DEFINE(ENABLE_TESTS, [], [whether we should compile the test-suite])])
 
+AC_CHECK_HEADER(sys/sendfile.h, [AC_DEFINE(LINUX_SENDFILE, [], [whether we have the linux sendfile api])])
+dnl TODO: we might need to check for the actual syntax....  
 
 
 AC_CHECK_HEADERS(iconv.h)