Add support for sending / reading to files; so far we just implement the linux sendfi...
[citadel.git] / libcitadel / configure.in
index eb3f4c0ed76de977763dd699cfcaa1dd2339f7c0..d61a071c30f964bb94d233e542b727e83c9beb64 100755 (executable)
@@ -74,6 +74,8 @@ fi
 
 AC_CHECK_HEADER(CUnit/CUnit.h, [AC_DEFINE(ENABLE_TESTS, [], [whether we should compile the test-suite])])
 
+AC_CHECK_HEADER(sys/sendfile.h, [AC_DEFINE(LINUX_SENDFILE, [], [whether we have the linux sendfile api])])
+dnl TODO: we might need to check for the actual syntax....  
 
 
 AC_CHECK_HEADERS(iconv.h)