Rewrote our local implementation of a Base64 encoder/decoder as specified
[citadel.git] / libcitadel / configure.in
index 2be9c363d79af1acb024c64fb369637f6f6881a2..d68a287285fb8067506cd9ad8f0a05a3c15c54ba 100755 (executable)
@@ -4,12 +4,9 @@ dnl
 
 dnl Ensure that libcitadel is configured with autoconf 2.52 or newer
 AC_PREREQ(2.52)
-
-AC_INIT(libcitadel, 903, http://uncensored.citadel.org)
-
+AC_INIT([libcitadel], m4_esyscmd_s([grep LIBCITADEL_VERSION lib/libcitadel.h | sed 's/[^0-9]*//g' ]),[http://uncensored.citadel.org])
 AC_CONFIG_SRCDIR(Makefile.in)
 AC_CONFIG_AUX_DIR(conftools)
-AC_CONFIG_SRCDIR(tests/Makefile.in)
 
 dnl
 dnl Set LIBREVISION to the ever-ascending libcitadel version number.
@@ -20,7 +17,7 @@ dnl Set LIBAGE to 0.
 dnl
 
 LIBCURRENT=4
-LIBREVISION=903
+LIBREVISION=m4_esyscmd_s([grep LIBCITADEL_VERSION lib/libcitadel.h | sed 's/[^0-9]*//g' ])
 LIBAGE=0
 
 sinclude(conftools/libtool.m4)
@@ -224,7 +221,7 @@ AC_C_CONST
 AC_TYPE_SIZE_T
 AC_CHECK_FUNCS(memmove bcopy)
 
-AC_CONFIG_FILES(Makefile libcitadel.pc tests/Makefile)
+AC_CONFIG_FILES(Makefile libcitadel.pc)
 AC_CONFIG_HEADER(sysdep.h)
 AC_OUTPUT