New build system for libcitadel, with autoconf and libtool
[citadel.git] / libcitadel / configure.in
index c8d8e06d5989d72c58d7e2271bf5d1059a8b5f8b..f700b3cfcfbbf7505ddb8a0e505861972212eb05 100755 (executable)
@@ -6,7 +6,6 @@ dnl Ensure that libcitadel is configured with autoconf 2.52 or newer
 AC_PREREQ(2.52)
 
 AC_INIT(citadel, 1.00, example@example.com)
-undefine([expat_version])
 
 AC_CONFIG_SRCDIR(Makefile.in)
 AC_CONFIG_AUX_DIR(conftools)
@@ -30,7 +29,6 @@ LIBAGE=0
 sinclude(conftools/libtool.m4)
 sinclude(conftools/ac_c_bigendian_cross.m4)
 
-AC_LIBTOOL_WIN32_DLL
 AC_PROG_LIBTOOL
 
 AC_SUBST(LIBCURRENT)
@@ -61,10 +59,6 @@ AC_HEADER_STDC
 
 dnl Checks for typedefs, structures, and compiler characteristics.
 
-dnl Note: Avoid using AC_C_BIGENDIAN because it does not
-dnl work in a cross compile.
-AC_C_BIGENDIAN_CROSS
-
 AC_C_CONST
 AC_TYPE_SIZE_T
 AC_CHECK_FUNCS(memmove bcopy)