Quick hack to buildpackages, use "buildpackages version" to simply have it tell you...
[citadel.git] / libcitadel / configure.in
index 0d21b1121d2f8317a90376acb0a4f078104d5234..fe0c76f4f5d190bc30ecf20a0a44554656e45d66 100755 (executable)
@@ -5,25 +5,22 @@ dnl
 dnl Ensure that libcitadel is configured with autoconf 2.52 or newer
 AC_PREREQ(2.52)
 
-AC_INIT(libcitadel, 2.8.13, http://uncensored.citadel.org)
+AC_INIT(libcitadel, 902, http://uncensored.citadel.org)
 
 AC_CONFIG_SRCDIR(Makefile.in)
 AC_CONFIG_AUX_DIR(conftools)
 AC_CONFIG_SRCDIR(tests/Makefile.in)
 
 dnl
-dnl Increment LIBREVISION if source code has changed at all
+dnl Set LIBREVISION to the ever-ascending libcitadel version number.
 dnl
-dnl If the API has changed, increment LIBCURRENT and set LIBREVISION to 0
+dnl If the API has changed, increment LIBCURRENT.
 dnl
-dnl If the API changes compatibly (i.e. simply adding a new function
-dnl without changing or removing earlier interfaces), then increment LIBAGE.
-dnl 
-dnl If the API changes incompatibly set LIBAGE back to 0
+dnl Set LIBAGE to 0.
 dnl
 
-LIBCURRENT=2
-LIBREVISION=813
+LIBCURRENT=4
+LIBREVISION=902
 LIBAGE=0
 
 sinclude(conftools/libtool.m4)
@@ -103,6 +100,36 @@ AC_TRY_COMPILE([
                ]
 )
 
+AC_MSG_CHECKING([whether your system likes memcpy + HKEY]) 
+AC_TRY_COMPILE([
+#define _GNU_SOURCE
+#include <ctype.h>
+#include <errno.h>
+#include <string.h>
+#include <unistd.h>
+#include <string.h>
+#include <stdio.h>
+#include <sys/select.h>
+#include <fcntl.h>
+#include <sys/types.h>
+
+#include "lib/libcitadel.h"
+],
+[
+       char foo[22];
+       memcpy(foo, HKEY("foo"));
+       
+],
+               [
+
+                 AC_MSG_RESULT([yes])
+               ],
+               [ 
+                 AC_DEFINE(UNDEF_MEMCPY, [], [whether we need to undefine memcpy])
+                 AC_MSG_RESULT([no])
+               ]
+)
+
 
 AC_CHECK_HEADERS(iconv.h)