(no commit message)
[citadel.git] / libcitadel / debian / rules
index 8cb082d473070ad3a3e64affb57c27424b9d7576..2219e78da7edff126e830a3682d69d1d4fe30ecc 100755 (executable)
@@ -11,10 +11,10 @@ DEB_BUILD_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
 
 CFLAGS = -Wall -g
 
-ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
-  CFLAGS += -O0
+ifneq (,$(findstring debug,$(DEB_BUILD_OPTIONS)))
+       CFLAGS += -O0 -ggdb -rdynamic -MD -MP 
 else
-  CFLAGS += -O2 -fno-strict-aliasing
+       CFLAGS += -O2
 endif
 
 build: build-stamp