fix source so that '-Wformat -Werror=format-security' doesn't stop us from compiling
[citadel.git] / libcitadel / debian / rules
index a0cddd79e2c434491d70e6a668eb5599ddcd31c7..7bfdf7efc795ceff9b717f896824b6363e772b1a 100755 (executable)
@@ -9,7 +9,7 @@ export DH_COMPAT = 5
 DEB_HOST_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
 DEB_BUILD_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
 
-CFLAGS = -Wall -g 
+CFLAGS = -Wall -g  -Wformat -Werror=format-security
 #-finline-functions
 LDFALGS =
 # -finline-functions