* this way the package builds again.
[citadel.git] / libcitadel / debian / rules
index 966239a9541931baef420e3a27d15b34e5e5764f..8cb082d473070ad3a3e64affb57c27424b9d7576 100755 (executable)
@@ -4,6 +4,8 @@
 # Uncomment this to turn on verbose mode.
 #export DH_VERBOSE=1
 
+export DH_COMPAT = 5
+
 DEB_HOST_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
 DEB_BUILD_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
 
@@ -32,7 +34,9 @@ clean:
        dh_testdir
        dh_testroot
        rm -f build-stamp install*-stamp
-       [ ! -f Makefile ] || $(MAKE) distclean
+
+       -$(MAKE) distclean
+
        dh_clean
 
 install: install-stamp