libical, expat, and libsieve are now *required*.
[citadel.git] / webcit / configure.ac
index eac01f714b3aa284ddf89c73f1c1ed7a58dc5d1f..00bc0c932ed452bc66b9ec9f0b805e68aa390a8e 100644 (file)
@@ -1,6 +1,6 @@
 dnl Process this file with autoconf to produce a configure script.
 dnl $Id$
-AC_INIT([WebCit], [7.33], [http://www.citadel.org/])
+AC_INIT([WebCit], [7.34], [http://www.citadel.org/])
 
 AC_SUBST(PROG_SUBDIRS)
 AC_DEFINE(PROG_SUBDIRS, [], [Program dirs])
@@ -23,7 +23,6 @@ else
        ssl_dir="$prefix/keys"
 fi
 
-AC_ARG_WITH(with_libical, [  --with-libical          use libical calendaring library])
 AC_ARG_WITH(with_zlib,    [  --with-zlib             use zlib compression if present])
 AC_ARG_WITH(ssl,
        [  --with-ssl=PATH         Specify path to OpenSSL installation ],
@@ -129,7 +128,7 @@ AC_TRY_RUN([
 dnl Check for iconv in external libiconv
 if test "$ok_iconv" = no; then
        AC_MSG_CHECKING(Checking for an external libiconv)
-       OLD_LDFLAGS=$LDFLAGS
+       OLD_LDFLAGS="$LDFLAGS"
        LDFLAGS="$LDFLAGS -liconv"
        AC_TRY_RUN([
                        #include <iconv.h>
@@ -145,7 +144,7 @@ if test "$ok_iconv" = no; then
                        ],
                        [ 
                          ok_iconv=no
-                         LDFLAGS=$OLDLDFLAGS
+                         LDFLAGS="$OLD_LDFLAGS"
                          AC_MSG_RESULT([no])
                        ]
                )
@@ -159,8 +158,6 @@ fi
 
 AC_CHECK_LIB(intl, libintl_bindtextdomain, [LDFLAGS="$LDFLAGS -lintl"])
 
-
-
 dnl Check for libcitadel
 AC_CHECK_HEADER(libcitadel.h,
        [AC_CHECK_LIB(citadel, libcitadel_version_string,
@@ -178,47 +175,22 @@ AC_CHECK_HEADER(libcitadel.h,
 )
 
 
-webcit_with_calendar_service=no
-dnl Checks for the libical calendaring library.
-if test "x$with_libical" != xno ; then
-        AC_CHECK_HEADERS(ical.h,
-                [AC_CHECK_LIB(ical, icalcomponent_new,
-                        [ok_libical=yes],,
-        )])
-fi
-
-if test "x$ok_libical" = xyes ; then
-
-       AC_TRY_RUN(
-               [
-#include <ical.h>
-main() {
-        int major, minor, v;
-        sscanf(ICAL_VERSION, "%d.%d", &major, &minor);
-        v = 100*major + minor;
-        printf("libical version: %i\n", v);
-        if (v >= 30) {
-                printf("This version is ok.\n");
-               return(0);
-       }
-       printf("libical 0.30 or newer required.\n");
-       printf("Citadel will be built without calendar support.\n");
-       return(1);
-}
-               ], 
+dnl Checks for the libical iCalendar library.
+AC_CHECK_HEADER(ical.h,
+       [AC_CHECK_LIB(ical, icalcomponent_new,
                [
                        LIBS="-lical $LIBS"
-                       AC_DEFINE(HAVE_LIBICAL,[],[whether we have libical available])
-                       webcit_with_calendar_service=yes
+               ],
+               [
+                       AC_MSG_ERROR(libical was not found and is required.  More info: http://www.citadel.org/doku.php/installation:start)
                ]
-       )
-fi
-ok_libical=$webcit_with_calendar_service
-
+       ,
+       )],
+       [
+               AC_MSG_ERROR(ical.h was not found and is required.  More info: http://www.citadel.org/doku.php/installation:start)
+       ]
+)
 
-if test "$webcit_with_calendar_service" == "yes"; then
-                       AC_DEFINE(WEBCIT_WITH_CALENDAR_SERVICE,[],[whether we can do with calendar.])
-fi
 
 dnl Checks for the zlib compression library.
 if test "x$with_zlib" != xno ; then
@@ -485,7 +457,6 @@ AC_OUTPUT(Makefile po/Makefile )
 
 echo ------------------------------------------------------------------------
 echo 'zlib compression:                ' $ok_zlib
-echo 'Calendar support:                ' $ok_libical
 echo 'Character set conversion support:' $ok_iconv
 echo 'National language support:       ' $ok_nls
 echo