Set version numbers and copyright dates for 8.04 release
[citadel.git] / webcit / configure.ac
index 5fe05bc1fd5e5dd2a6931a7769245ca044135280..00bd6e0e4ea54186358c260a4ccbbe2c64d149cf 100644 (file)
@@ -1,6 +1,6 @@
 dnl Process this file with autoconf to produce a configure script.
 dnl $Id$
-AC_INIT([WebCit], [7.80], [http://www.citadel.org/])
+AC_INIT([WebCit], [8.04], [http://www.citadel.org/])
 
 
 AC_SUBST(PROG_SUBDIRS)
@@ -122,6 +122,13 @@ dnl Checks for typedefs, structures, and compiler characteristics.
 AC_C_CONST
 AC_TYPE_OFF_T
 AC_TYPE_SIZE_T
+dnl Check the size of various builtin types; see typesize.h (error)
+AC_CHECK_SIZEOF(char, 0)
+AC_CHECK_SIZEOF(short, 0)
+AC_CHECK_SIZEOF(int, 0)
+AC_CHECK_SIZEOF(long, 0)
+AC_CHECK_SIZEOF(long unsigned int, 0)
+AC_CHECK_SIZEOF(size_t, 0)
 dnl AC_HEADER_TIME
 
 dnl Checks for library functions.
@@ -394,7 +401,7 @@ fi
 if test "$ok_nls" != "no"; then
        AC_MSG_RESULT(WebCit will be built with national language support.)
        AC_DEFINE(ENABLE_NLS, [], [whether we have NLS support])
-       PROG_SUBDIRS="$PROG_SUBDIRS po"
+       PROG_SUBDIRS="$PROG_SUBDIRS po/webcit/"
 else
        AC_MSG_RESULT(WebCit will be built without national language support.)
 fi
@@ -500,7 +507,7 @@ if test "$abs_srcdir" != "$abs_builddir"; then
    CFLAGS="$CFLAGS -I $abs_builddir"
 fi
 AC_CONFIG_HEADER(sysdep.h)
-AC_OUTPUT(Makefile po/Makefile tests/Makefile)
+AC_OUTPUT(Makefile po/webcit/Makefile tests/Makefile)
 
 if test "$abs_srcdir" != "$abs_builddir"; then
    ln -s $abs_srcdir/static $abs_builddir