* configure.ac: changed 'libcitadel' message to 'webcit'
[citadel.git] / webcit / configure.ac
index 88fd8199b267e0041e4453b13bab2c12778c96a2..32aa525baca04f5f06e9b94b58fe0b03af912d7a 100644 (file)
@@ -1,6 +1,6 @@
 dnl Process this file with autoconf to produce a configure script.
 dnl $Id$
-AC_INIT([WebCit], [7.43], [http://www.citadel.org/])
+AC_INIT([WebCit], [7.66], [http://www.citadel.org/])
 
 
 AC_SUBST(PROG_SUBDIRS)
@@ -116,6 +116,7 @@ dnl  libcitadel will bring libz, so we don't need it here.     LDFLAGS="-lz $LDF
        AC_DEFINE(HAVE_ZLIB, [], [define this if you have zlib compression available])
 fi
 
+
 dnl Here is the check for a libc integrated iconv
 AC_ARG_ENABLE(iconv,
        [  --disable-iconv         do not use iconv charset conversion],
@@ -166,12 +167,13 @@ if test "$ok_iconv" = no; then
                )
 fi     
 if test "$ok_iconv" != "no"; then
-       AC_MSG_RESULT(WebCit will be built with character set conversion.)
+       AC_MSG_RESULT(webcit will be built with character set conversion.)
        AC_DEFINE(HAVE_ICONV,[],[whether we have iconv for charset conversion])
 else
-       AC_MSG_RESULT(WebCit will be built without character set conversion.)
+       AC_MSG_RESULT(webcit will be built without character set conversion.)
 fi
 
+
 AC_CHECK_LIB(intl, libintl_bindtextdomain, [LDFLAGS="$LDFLAGS -lintl"])
 
 
@@ -463,10 +465,32 @@ AC_ARG_WITH(editordir,
 )
 AC_DEFINE_UNQUOTED(EDITORDIR, "$editordir", [where to find our mail editor])
 
-./mk_module_init.sh
+abs_srcdir="`cd $srcdir && pwd`"
+abs_builddir="`pwd`"
+if test "$abs_srcdir" != "$abs_builddir"; then
+   CFLAGS="$CFLAGS -I $abs_builddir"
+fi
 AC_CONFIG_HEADER(sysdep.h)
 AC_OUTPUT(Makefile po/Makefile )
 
+if test "$abs_srcdir" != "$abs_builddir"; then
+   ln -s $abs_srcdir/static $abs_builddir
+   ln -s $abs_srcdir/tiny_mce $abs_builddir
+   ln -s $abs_srcdir/*.h $abs_builddir
+   make mkdir-init
+   
+else
+dnl just run it on devel systems and if non vdir build.
+   if test -d .svn; then
+      ./mk_module_init.sh
+   fi
+fi
+
+if test -n "$srcdir"; then 
+   export srcdir=.
+fi
+
+
 echo ------------------------------------------------------------------------
 echo 'Character set conversion support:' $ok_iconv
 echo 'National language support:       ' $ok_nls