Version number to 8.13 for upcoming release.
[citadel.git] / webcit / configure.ac
index 4ce75792be46007f1b688ecb4d54d1d261349926..5fc9194cee7d0ec157dd827de91ab55382970b93 100644 (file)
@@ -1,6 +1,6 @@
 dnl Process this file with autoconf to produce a configure script.
 dnl $Id$
-AC_INIT([WebCit], [8.10], [http://www.citadel.org/])
+AC_INIT([WebCit], [8.13], [http://www.citadel.org/])
 
 
 AC_SUBST(PROG_SUBDIRS)
@@ -400,6 +400,11 @@ AC_ARG_WITH(ssldir,
 )
 AC_DEFINE_UNQUOTED(SSL_DIR, "$ssl_dir", [were should we put our keys?])
 
+
+
+
+AC_CHECK_FUNCS(strftime_l uselocale gettext)
+
 if test "$ok_nls" != "no"; then
        AC_CHECK_PROG(ok_xgettext, xgettext, yes, no)
        ok_nls=$ok_xgettext
@@ -416,8 +421,11 @@ if test "$ok_nls" != "no"; then
 fi
 
 if test "$ok_nls" != "no"; then
-       AC_CHECK_FUNCS(strftime_l uselocale gettext)
+       AC_MSG_RESULT(WebCit will be built with national language support.)
+       AC_DEFINE(ENABLE_NLS, [], [whether we have NLS support])
        PROG_SUBDIRS="$PROG_SUBDIRS po/webcit/"
+else
+       AC_MSG_RESULT(WebCit will be built without national language support.)
 fi
 
 AC_SUBST(SETUP_LIBS)