+ link gettext.c into setup, so we know the servers locales
[citadel.git] / webcit / configure.ac
index 3ac9f2eb048106cc9533a51f0ddafdc2f7915c9c..61353f819e4904e229bcaf2f8f50f006cf369a0f 100644 (file)
@@ -24,7 +24,6 @@ else
        ssl_dir="$prefix/keys"
 fi
 
-AC_ARG_WITH(with_zlib,    [  --with-zlib             use zlib compression if present])
 AC_ARG_WITH(ssl,
        [  --with-ssl=PATH         Specify path to OpenSSL installation ],
        [
@@ -52,6 +51,8 @@ case "$host" in
        *-*-solaris*)
                PTHREAD_DEFS='-D_REENTRANT -D_PTHREADS'
        ;;
+       *-*-darwin*)
+               LIBS=-lintl
 esac
 AC_SUBST(PTHREAD_DEFS)
 
@@ -62,10 +63,10 @@ dnl Configure compiler flags for GCC
 if test "$GCC" = yes; then
        case "$host" in
                *-*-solaris*)
-                       CFLAGS="$CFLAGS -Wall -Wno-char-subscripts"
+                       CFLAGS="$CFLAGS -Wall -Wno-char-subscripts --pedantic"
                ;;
                *)
-                       CFLAGS="$CFLAGS -Wall"
+                       CFLAGS="$CFLAGS -Wall --pedantic"
                ;;
        esac
 fi
@@ -98,7 +99,7 @@ dnl Checks for library functions.
 AC_TYPE_SIGNAL
 dnl AC_FUNC_VPRINTF
 AC_REPLACE_FUNCS(snprintf)
-AC_CHECK_HEADERS(fcntl.h limits.h sys/time.h unistd.h iconv.h)
+AC_CHECK_HEADERS(fcntl.h limits.h sys/time.h unistd.h iconv.h xlocale.h)
 
 
 dnl Here is the check for a libc integrated iconv
@@ -159,54 +160,44 @@ fi
 
 AC_CHECK_LIB(intl, libintl_bindtextdomain, [LDFLAGS="$LDFLAGS -lintl"])
 
-dnl Check for libcitadel
-AC_CHECK_HEADER(libcitadel.h,
-       [AC_CHECK_LIB(citadel, libcitadel_version_string,
+
+dnl Checks for the libical iCalendar library.
+AC_CHECK_HEADER(libical/ical.h,
+       [AC_CHECK_LIB(ical, icaltimezone_set_tzid_prefix,
                [
-                       LIBS="-lcitadel $LIBS"
+                       LIBS="-lical $LIBS"
                ],
                [
-                       AC_MSG_ERROR(libcitadel was not found or is not usable.  Please install libcitadel.)
+                       AC_MSG_ERROR(libical was not found and is required.  More info: http://www.citadel.org/doku.php/installation:start)
                ]
        ,
        )],
        [
-               AC_MSG_ERROR(libcitadel.h was not found or is not usable.  Please install libcitadel.)
+               AC_MSG_ERROR(libical/ical.h was not found and is required.  More info: http://www.citadel.org/doku.php/installation:start)
        ]
 )
 
 
-dnl Checks for the libical iCalendar library.
-AC_CHECK_HEADER(libical/ical.h,
-       [AC_CHECK_LIB(ical, icalcomponent_as_ical_string_r,
+dnl Check for libcitadel
+AC_CHECK_HEADER(libcitadel.h,
+       [AC_CHECK_LIB(citadel, libcitadel_version_string,
                [
-                       LIBS="-lical $LIBS"
+                       LIBS="-lcitadel $LIBS"
+                       SETUP_LIBS="-lcitadel $SETUP_LIBS"
                ],
                [
-                       AC_MSG_ERROR(libical was not found and is required.  More info: http://www.citadel.org/doku.php/installation:start)
+                       AC_MSG_ERROR(libcitadel was not found or is not usable.  Please install libcitadel.)
                ]
        ,
        )],
        [
-               AC_MSG_ERROR(libical/ical.h was not found and is required.  More info: http://www.citadel.org/doku.php/installation:start)
+               AC_MSG_ERROR(libcitadel.h was not found or is not usable.  Please install libcitadel.)
        ]
 )
 
 
-dnl Checks for the zlib compression library.
-if test "x$with_zlib" != xno ; then
-        AC_CHECK_HEADERS(zlib.h,
-                [AC_CHECK_LIB(z, zlibVersion,
-                        [ok_zlib=yes],,
-        )])
-fi
-
-if test "x$ok_zlib" = xyes ; then
-        LIBS="-lz $LIBS"
-        AC_DEFINE(HAVE_ZLIB,[],[whether we have zlib])
-fi
-
 
+found_ssl=no
 # The big search for OpenSSL
 if test "$with_ssl" != "no"; then
        saved_LIBS="$LIBS"
@@ -289,6 +280,7 @@ if test "$with_ssl" != "no"; then
        
        if test "x$ac_cv_openssldir" != "xno" ; then
                AC_DEFINE(HAVE_OPENSSL,[],[whethe we have openssl])
+               found_ssl=yes
                LIBS="-lssl -lcrypto $LIBS"
                dnl Need to recover ssldir - test above runs in subshell
                ssldir=$ac_cv_openssldir
@@ -324,6 +316,10 @@ AC_ARG_WITH(ssldir,
                        [ if test "x$withval" != "xno" ; then
                                              
                                                  ssl_dir="$withval"
+                                                 if test "$found_ssl" = "no"; then
+                                                    echo "Your setup was incomplete; ssldir doesn't make sense without openssl"
+                                                    exit
+                                                 fi
                          fi
                        AC_SUBST(MAKE_SSL_DIR)
                        ]
@@ -458,7 +454,6 @@ AC_CONFIG_HEADER(sysdep.h)
 AC_OUTPUT(Makefile po/Makefile )
 
 echo ------------------------------------------------------------------------
-echo 'zlib compression:                ' $ok_zlib
 echo 'Character set conversion support:' $ok_iconv
 echo 'National language support:       ' $ok_nls
 echo