Revert "Remove ENABLE_NLS definition. Either we HAVE_USELOCALE or we don't translate...
[citadel.git] / webcit / configure.ac
index 4ce75792be46007f1b688ecb4d54d1d261349926..6f3a7bc775ebfd4a6901e17da0984ff2a96a86c4 100644 (file)
@@ -400,6 +400,11 @@ AC_ARG_WITH(ssldir,
 )
 AC_DEFINE_UNQUOTED(SSL_DIR, "$ssl_dir", [were should we put our keys?])
 
+
+
+
+AC_CHECK_FUNCS(strftime_l uselocale gettext)
+
 if test "$ok_nls" != "no"; then
        AC_CHECK_PROG(ok_xgettext, xgettext, yes, no)
        ok_nls=$ok_xgettext
@@ -416,8 +421,11 @@ if test "$ok_nls" != "no"; then
 fi
 
 if test "$ok_nls" != "no"; then
-       AC_CHECK_FUNCS(strftime_l uselocale gettext)
+       AC_MSG_RESULT(WebCit will be built with national language support.)
+       AC_DEFINE(ENABLE_NLS, [], [whether we have NLS support])
        PROG_SUBDIRS="$PROG_SUBDIRS po/webcit/"
+else
+       AC_MSG_RESULT(WebCit will be built without national language support.)
 fi
 
 AC_SUBST(SETUP_LIBS)