Revert "Remove ENABLE_NLS definition. Either we HAVE_USELOCALE or we don't translate...
[citadel.git] / webcit / configure.ac
index a7738d78418f283c83e682caacef3aa1654bfcbe..6f3a7bc775ebfd4a6901e17da0984ff2a96a86c4 100644 (file)
@@ -1,26 +1,29 @@
 dnl Process this file with autoconf to produce a configure script.
 dnl $Id$
-AC_INIT(webserver.c)
+AC_INIT([WebCit], [8.10], [http://www.citadel.org/])
 
 
-PACKAGE=webcit
-VERSION=7.12
-AC_DEFINE_UNQUOTED(PACKAGE, "$PACKAGE")
-AC_DEFINE_UNQUOTED(VERSION, "$VERSION")
-AC_SUBST(PACKAGE)
-AC_SUBST(VERSION)
-
 AC_SUBST(PROG_SUBDIRS)
+AC_DEFINE(PROG_SUBDIRS, [], [Program dirs])
 AC_CANONICAL_HOST
 AC_PROG_INSTALL
 missing_dir=`cd $ac_aux_dir && pwd`
 AM_MISSING_PROG(AUTOCONF, autoconf, $missing_dir)
 AM_MISSING_PROG(ACLOCAL, aclocal, $missing_dir)
+
+dnl Make sure we see all GNU and Solaris extensions.
+AC_GNU_SOURCE
+
 AC_CHECK_PROG(SED, sed, sed, no)
 AC_PREFIX_DEFAULT(/usr/local/webcit)
+if test "$prefix" = NONE; then
+       AC_DEFINE_UNQUOTED(WEBCITDIR, "$ac_default_prefix", [define this to the Citadel home directory])
+       ssl_dir="$ac_default_prefix/keys"
+else
+       AC_DEFINE_UNQUOTED(WEBCITDIR, "$prefix", [define this to the Citadel home directory])
+       ssl_dir="$prefix/keys"
+fi
 
-AC_ARG_WITH(with_libical, [  --with-libical          use libical calendaring library])
-AC_ARG_WITH(with_zlib,    [  --with-zlib             use zlib compression if present])
 AC_ARG_WITH(ssl,
        [  --with-ssl=PATH         Specify path to OpenSSL installation ],
        [
@@ -48,6 +51,8 @@ case "$host" in
        *-*-solaris*)
                PTHREAD_DEFS='-D_REENTRANT -D_PTHREADS'
        ;;
+       *-*-darwin*)
+               LIBS=-lintl
 esac
 AC_SUBST(PTHREAD_DEFS)
 
@@ -58,9 +63,11 @@ dnl Configure compiler flags for GCC
 if test "$GCC" = yes; then
        case "$host" in
                *-*-solaris*)
+dnl                    CFLAGS="$CFLAGS -Wall -Wno-char-subscripts --pedantic"
                        CFLAGS="$CFLAGS -Wall -Wno-char-subscripts"
                ;;
                *)
+dnl                    CFLAGS="$CFLAGS -Wall --pedantic"
                        CFLAGS="$CFLAGS -Wall"
                ;;
        esac
@@ -80,8 +87,34 @@ AC_SEARCH_LIBS(connect, socket)
 dnl Checks for header files.
 AC_HEADER_STDC
 dnl AC_HEADER_SYS_WAIT
-AC_CHECK_HEADERS(fcntl.h limits.h sys/time.h unistd.h)
 
+AC_CACHE_CHECK(
+       [for call semantics from getpwuid_r], 
+       ac_cv_call_getpwuid_r,
+       [AC_TRY_COMPILE([#include <sys/types.h>
+#include <pwd.h>], 
+                         [
+                               struct passwd pw, *pwp;
+                               char pwbuf[64];
+                               uid_t uid;
+
+                               getpwuid_r(uid, &pw, pwbuf, sizeof(pwbuf), &pwp);
+                       ],
+                       ac_cv_call_getpwuid_r=yes, 
+                       ac_cv_call_getpwuid_r=no)
+       ])
+
+if test $ac_cv_call_getpwuid_r = no; then
+       AC_DEFINE(SOLARIS_GETPWUID,[],[do we need to use solaris call syntax?])
+       AC_DEFINE(SOLARIS_LOCALTIME_R,[], [do we need to use soralis call syntax?])
+       AC_DEFINE(F_UID_T, "%ld", [whats the matching format string for uid_t?])
+       AC_DEFINE(F_PID_T, "%ld",  [whats the matching format string for pid_t?])
+       AC_DEFINE(F_XPID_T, "%lx",  [whats the matching format string for xpid_t?])
+else
+       AC_DEFINE(F_UID_T, "%d",  [whats the matching format string for uid_t?])
+       AC_DEFINE(F_PID_T, "%d",  [whats the matching format string for pid_t?])
+       AC_DEFINE(F_XPID_T, "%x",  [whats the matching format string for xpid_t?])
+fi
 
 
 
@@ -89,63 +122,156 @@ dnl Checks for typedefs, structures, and compiler characteristics.
 AC_C_CONST
 AC_TYPE_OFF_T
 AC_TYPE_SIZE_T
+dnl Check the size of various builtin types; see typesize.h (error)
+AC_CHECK_SIZEOF(char, 0)
+AC_CHECK_SIZEOF(short, 0)
+AC_CHECK_SIZEOF(int, 0)
+AC_CHECK_SIZEOF(long, 0)
+AC_CHECK_SIZEOF(long unsigned int, 0)
+AC_CHECK_SIZEOF(size_t, 0)
 dnl AC_HEADER_TIME
 
 dnl Checks for library functions.
 AC_TYPE_SIGNAL
 dnl AC_FUNC_VPRINTF
-dnl AC_CHECK_FUNCS(strerror)
 AC_REPLACE_FUNCS(snprintf)
+AC_CHECK_HEADER(CUnit/CUnit.h, [AC_DEFINE(ENABLE_TESTS, [], [whether we should compile the test-suite])])
 
-dnl Checks for the libical calendaring library.
-if test "x$with_libical" != xno ; then
-        AC_CHECK_HEADERS(ical.h,
-                [AC_CHECK_LIB(ical, icalcomponent_new,
-                        [ok_libical=yes],,
-        )])
-fi
+AC_CHECK_HEADERS(fcntl.h limits.h sys/time.h unistd.h iconv.h xlocale.h)
 
-if test "x$ok_libical" = xyes ; then
+dnl Checks for the zlib compression library.
+saved_CFLAGS="$CFLAGS"
+CFLAGS="$CFLAGS $SERVER_LIBS"
+AC_CHECK_HEADER(zlib.h,
+       [AC_CHECK_LIB(z, zlibVersion,
+               [
+                       LIBS="-lz $LIBS $SERVER_LIBS"
+               ],
+               [
+                       AC_MSG_ERROR(zlib was not found or is not usable.  Please install zlib.)
+               ]
+       ,
+       )],
+       [
+               AC_MSG_ERROR(zlib.h was not found or is not usable.  Please install zlib.)
+       ]
+)
+CFLAGS="$saved_CFLAGS"
 
-       AC_TRY_RUN(
+dnl Here is the check for a libc integrated iconv
+AC_ARG_ENABLE(iconv,
+       [  --disable-iconv         do not use iconv charset conversion],
+       ok_iconv=no, ok_iconv=yes)
+
+AC_MSG_CHECKING(Checking to see if your system supports iconv)
+AC_TRY_RUN([
+       #include <iconv.h>
+       main() {
+               iconv_t ic = (iconv_t)(-1) ;
+               ic = iconv_open("UTF-8", "us-ascii");
+               iconv_close(ic);
+               exit(0);
+       }
+ ],
                [
-#include <ical.h>
-main() {
-        int major, minor, v;
-        sscanf(ICAL_VERSION, "%d.%d", &major, &minor);
-        v = 100*major + minor;
-        printf("libical version: %i\n", v);
-        if (v >= 24) {
-                printf("This version is ok.\n");
-               return(0);
-       }
-       printf("libical 0.24 or newer required.\n");
-       printf("Citadel will be built without calendar support.\n");
-       return(1);
-}
-               ], 
+                 ok_iconv=yes
+                 AC_MSG_RESULT([yes])
+               ],
+               [ 
+                 ok_iconv=no
+                 AC_MSG_RESULT([no])
+               ]
+)
+
+dnl Check for iconv in external libiconv
+if test "$ok_iconv" = no; then
+       AC_MSG_CHECKING(Checking for an external libiconv)
+       OLD_LDFLAGS="$LDFLAGS"
+       LDFLAGS="$LDFLAGS -liconv"
+       AC_TRY_RUN([
+                       #include <iconv.h>
+                       main() {
+                               iconv_t ic = (iconv_t)(-1) ;
+                               ic = iconv_open("UTF-8", "us-ascii");
+                               iconv_close(ic);
+                       }
+               ],
+                       [
+                         ok_iconv=yes
+                         AC_MSG_RESULT([yes])
+                       ],
+                       [ 
+                         ok_iconv=no
+                         LDFLAGS="$OLD_LDFLAGS"
+                         AC_MSG_RESULT([no])
+                       ]
+               )
+fi     
+if test "$ok_iconv" != "no"; then
+       AC_MSG_RESULT(webcit will be built with character set conversion.)
+       AC_DEFINE(HAVE_ICONV,[],[whether we have iconv for charset conversion])
+else
+       AC_MSG_RESULT(webcit will be built without character set conversion.)
+fi
+
+
+AC_CHECK_LIB(intl, libintl_bindtextdomain, [LDFLAGS="$LDFLAGS -lintl"])
+
+
+dnl Checks for the libical iCalendar library.
+AC_CHECK_HEADER(libical/ical.h,
+       [AC_CHECK_LIB(ical, icaltimezone_set_tzid_prefix,
                [
                        LIBS="-lical $LIBS"
-                       AC_DEFINE(HAVE_LIBICAL)
+               ],
+               [
+                       AC_MSG_ERROR(libical was not found and is required.  More info: http://www.citadel.org/doku.php/installation:start)
                ]
-       )
-fi
+       ,
+       )],
+       [
+               AC_MSG_ERROR(libical/ical.h was not found and is required.  More info: http://www.citadel.org/doku.php/installation:start)
+       ]
+)
 
 
+dnl Check for libcitadel
+AC_CHECK_HEADER(libcitadel.h,
+       [AC_CHECK_LIB(citadel, libcitadel_version_string,
+               [
+                       LIBS="-lcitadel $LIBS"
+                       SETUP_LIBS="-lcitadel $SETUP_LIBS"
+               ],
+               [
+                       AC_MSG_ERROR(libcitadel was not found or is not usable.  Please install libcitadel.)
+               ]
+       ,
+       )],
+       [
+               AC_MSG_ERROR(libcitadel.h was not found or is not usable.  Please install libcitadel.)
+       ]
+)
 
-dnl Checks for the zlib compression library.
-if test "x$with_zlib" != xno ; then
-        AC_CHECK_HEADERS(zlib.h,
-                [AC_CHECK_LIB(z, zlibVersion,
-                        [ok_zlib=yes],,
-        )])
-fi
 
-if test "x$ok_zlib" = xyes ; then
-        LIBS="-lz $LIBS"
-        AC_DEFINE(HAVE_ZLIB)
-fi
+dnl Checks for the Expat XML parser.
+AC_CHECK_HEADER(expat.h,
+       [AC_CHECK_LIB(expat, XML_ParserCreateNS,
+               [
+                       LIBS="-lexpat $LIBS"
+               ],
+               [
+                       AC_MSG_ERROR(The Expat XML parser was not found and is required.  More info: http://www.citadel.org/doku.php/installation:start)
+               ]
+       ,
+       )],
+       [
+               AC_MSG_ERROR(expat.h was not found and is required.  More info: http://www.citadel.org/doku.php/installation:start)
+       ]
+)
+
 
+
+found_ssl=no
 # The big search for OpenSSL
 if test "$with_ssl" != "no"; then
        saved_LIBS="$LIBS"
@@ -227,7 +353,8 @@ if test "$with_ssl" != "no"; then
        CFLAGS="$saved_CFLAGS"
        
        if test "x$ac_cv_openssldir" != "xno" ; then
-               AC_DEFINE(HAVE_OPENSSL)
+               AC_DEFINE(HAVE_OPENSSL,[],[whethe we have openssl])
+               found_ssl=yes
                LIBS="-lssl -lcrypto $LIBS"
                dnl Need to recover ssldir - test above runs in subshell
                ssldir=$ac_cv_openssldir
@@ -255,68 +382,28 @@ if test "$with_ssl" != "no"; then
                fi
        fi
 fi
-
-dnl Here is the check for a usable iconv
-
-AC_ARG_ENABLE(iconv,
-       [  --disable-iconv         do not use iconv charset conversion],
-       ok_iconv=no, ok_iconv=yes)
-
-if test "$ok_nls" != "no"; then
-       AC_MSG_RESULT(Checking to see if your system supports iconv...)
-       AC_TRY_RUN([
-               #include <iconv.h>
-               main() {
-                       iconv_t ic = (iconv_t)(-1) ;
-                       ic = iconv_open("UTF-8", "us-ascii");
-                       iconv_close(ic);
-                       exit(0);
-               }
-       ],
-               ok_iconv=yes,
-               ok_iconv=no
-       )
-fi
-
-if test "$ok_iconv" != "no"; then
-       AC_MSG_RESULT(WebCit will be built with character set conversion.)
-       AC_DEFINE(HAVE_ICONV)
-else
-       AC_MSG_RESULT(WebCit will be built without character set conversion.)
-fi
-
+dnl Checks for the SSLdir
+dnl this is a bit different than the rest, 
+dnl because of the citadel used to have a keys/ subdir.
+AC_ARG_WITH(ssldir, 
+                   [  --with-ssldir          directory to store the ssl certificates under],
+                       [ if test "x$withval" != "xno" ; then
+                                             
+                                                 ssl_dir="$withval"
+                                                 if test "$found_ssl" = "no"; then
+                                                    echo "Your setup was incomplete; ssldir doesn't make sense without openssl"
+                                                    exit
+                                                 fi
+                         fi
+                       AC_SUBST(MAKE_SSL_DIR)
+                       ]
+)
+AC_DEFINE_UNQUOTED(SSL_DIR, "$ssl_dir", [were should we put our keys?])
 
 
-dnl Here is the check for libintl etc.
 
-AC_ARG_ENABLE(nls,
-       [  --disable-nls           do not use Native Language Support],
-       ok_nls=no, ok_nls=yes)
 
-if test "$ok_nls" != "no"; then
-       AC_MSG_RESULT(Checking for per-thread NLS support...)
-       AC_TRY_RUN([
-                #define _GNU_SOURCE
-                #include <libintl.h>
-                #include <locale.h>
-                #include <time.h>
-                main() {
-                        char *foo = NULL;
-                        char baz[32];
-                       struct tm *tm;
-                        uselocale(LC_GLOBAL_LOCALE);
-                        foo = gettext("bar");
-                       if (0) {
-                               strftime_l(baz, sizeof baz, "%c", tm, LC_GLOBAL_LOCALE);
-                       }
-                        exit(0);
-               }
-       ],
-               ok_uselocale=yes,
-               ok_uselocale=no
-       )
-       ok_nls=$ok_uselocale
-fi
+AC_CHECK_FUNCS(strftime_l uselocale gettext)
 
 if test "$ok_nls" != "no"; then
        AC_CHECK_PROG(ok_xgettext, xgettext, yes, no)
@@ -335,61 +422,134 @@ fi
 
 if test "$ok_nls" != "no"; then
        AC_MSG_RESULT(WebCit will be built with national language support.)
-       AC_DEFINE(ENABLE_NLS)
-       PROG_SUBDIRS="$PROG_SUBDIRS po"
+       AC_DEFINE(ENABLE_NLS, [], [whether we have NLS support])
+       PROG_SUBDIRS="$PROG_SUBDIRS po/webcit/"
 else
        AC_MSG_RESULT(WebCit will be built without national language support.)
 fi
 
 AC_SUBST(SETUP_LIBS)
 
+dnl disable backtrace if we don't want it.
+AC_ARG_WITH(gprof, 
+                   [  --with-gprof          enable profiling],
+                       [ if test "x$withval" != "xno" ; then
+                            CFLAGS="$CFLAGS  -pg "
+                            LDFLAGS="$LDFLAGS  -pg "
+                         fi
+                       ]
+)
+
+dnl disable backtrace if we don't want it.
+AC_ARG_WITH(backtrace, 
+                   [  --with-backtrace          enable backtrace dumps in the syslog],
+                       [ if test "x$withval" != "xno" ; then
+                            CFLAGS="$CFLAGS  -rdynamic "
+                            LDFLAGS="$LDFLAGS  -rdynamic "
+                             AC_CHECK_FUNCS(backtrace)
+                         fi
+                       ]
+)
 
 if test "$prefix" = NONE; then
-       LOCALEDIR=$ac_default_prefix
-       WWWDIR=$ac_default_prefix
-       EDITORDIR=$ac_default_prefix/tiny_mce
+       datadir=$ac_default_prefix
+       localedir=$ac_default_prefix
+       wwwdir=$ac_default_prefix
+       rundir=$ac_default_prefix
+       editordir=$ac_default_prefix/tiny_mce
 else
-       LOCALEDIR=$prefix
-       WWWDIR=$prefix
-       EDITORDIR=$prefix/tiny_mce
+       localedir=$prefix
+       wwwdir=$prefix
+       datadir=$prefix
+       rundir=$prefix
+       editordir=$prefix/tiny_mce
 fi
 
 dnl where to put the locale files
 AC_ARG_WITH(localedir, 
                    [  --with-localedir          directory to put the locale files to],
                        [ if test "x$withval" != "xno" ; then
-                                                 LOCALEDIR=$withval
+                           localedir=$withval
                          fi
                        ]
 )
+AC_DEFINE_UNQUOTED(LOCALEDIR, "$localedir",[where to find our pot files])
+LOCALEDIR=$localedir
 AC_SUBST(LOCALEDIR)
 
 dnl Checks where to put our templates
 AC_ARG_WITH(wwwdir, 
                    [  --with-wwwdir             directory to put our templates],
                        [ if test "x$withval" != "xno" ; then
-                                                 WWWDIR=$withval
+                               wwwdir=$withval
                          fi
                        ]
 )
+AC_DEFINE_UNQUOTED(WWWDIR, "$wwwdir", [where to find our templates and pics])
+WWWDIR=$wwwdir
 AC_SUBST(WWWDIR)
 
+
+dnl Checks for the run-dir for the sockets
+AC_ARG_WITH(rundir, 
+                       [  --with-rundir           directory to place runtime files (UDS) to?],
+                       [ if test "x$withval" != "xno" ; then
+                                           AC_DEFINE(HAVE_RUN_DIR, [], [should we put our non volatile files elsewhere?])
+                                               
+                                               rundir=$withval
+                                               AC_SUBST(MAKE_RUN_DIR)
+                         fi
+                       ]
+)
+AC_DEFINE_UNQUOTED(RUNDIR, "$rundir", [define, where the config should go in unix style])
+
+dnl Checks for the Datadir
+AC_ARG_WITH(datadir, 
+                   [  --with-datadir          directory to store the databases under],
+                       [ if test "x$withval" != "xno" ; then
+                                             datadir=$withval
+                         fi
+                       ]
+)
+AC_DEFINE_UNQUOTED(DATADIR, "$datadir",[define, if the user suplied a data-directory to use.])
+
 dnl Checks where to put our editor
 AC_ARG_WITH(editordir, 
                    [  --with-editordir             directory to put our editor],
                        [ if test "x$withval" != "xno" ; then
-                                                 EDITORDIR=$withval
+                               editordir=$withval
                          fi
                        ]
 )
-AC_SUBST(EDITORDIR)
+AC_DEFINE_UNQUOTED(EDITORDIR, "$editordir", [where to find our mail editor])
+
+abs_srcdir="`cd $srcdir && pwd`"
+abs_builddir="`pwd`"
+if test "$abs_srcdir" != "$abs_builddir"; then
+   CFLAGS="$CFLAGS -I $abs_builddir"
+fi
+AC_CONFIG_HEADER(sysdep.h)
+AC_OUTPUT(Makefile po/webcit/Makefile tests/Makefile)
+
+if test "$abs_srcdir" != "$abs_builddir"; then
+   ln -s $abs_srcdir/static $abs_builddir
+   ln -s $abs_srcdir/tiny_mce $abs_builddir
+   ln -s $abs_srcdir/*.h $abs_builddir
+   make mkdir-init
+   
+else
+dnl just run it on devel systems and if non vdir build.
+   if test -d .svn; then
+      ./mk_module_init.sh
+   fi
+fi
 
+if test -n "$srcdir"; then 
+   export srcdir=.
+fi
 
-AC_OUTPUT(Makefile po/Makefile )
 
 echo ------------------------------------------------------------------------
-echo 'zlib compression:                ' $ok_zlib
-echo 'Calendar support:                ' $ok_libical
 echo 'Character set conversion support:' $ok_iconv
 echo 'National language support:       ' $ok_nls
 echo