* add gettext tokens to the tabbed api
[citadel.git] / webcit / configure.ac
index 6601635f4d6c215258a66695f77dee100c8d4884..786e43a2deec4a500e69b5c2f41aecb0b1bcfffb 100644 (file)
@@ -24,7 +24,6 @@ else
        ssl_dir="$prefix/keys"
 fi
 
-AC_ARG_WITH(with_zlib,    [  --with-zlib             use zlib compression if present])
 AC_ARG_WITH(ssl,
        [  --with-ssl=PATH         Specify path to OpenSSL installation ],
        [
@@ -52,6 +51,8 @@ case "$host" in
        *-*-solaris*)
                PTHREAD_DEFS='-D_REENTRANT -D_PTHREADS'
        ;;
+       *-*-darwin*)
+               LIBS=-lintl
 esac
 AC_SUBST(PTHREAD_DEFS)
 
@@ -98,7 +99,7 @@ dnl Checks for library functions.
 AC_TYPE_SIGNAL
 dnl AC_FUNC_VPRINTF
 AC_REPLACE_FUNCS(snprintf)
-AC_CHECK_HEADERS(fcntl.h limits.h sys/time.h unistd.h iconv.h)
+AC_CHECK_HEADERS(fcntl.h limits.h sys/time.h unistd.h iconv.h xlocale.h)
 
 
 dnl Here is the check for a libc integrated iconv
@@ -159,54 +160,43 @@ fi
 
 AC_CHECK_LIB(intl, libintl_bindtextdomain, [LDFLAGS="$LDFLAGS -lintl"])
 
-dnl Check for libcitadel
-AC_CHECK_HEADER(libcitadel.h,
-       [AC_CHECK_LIB(citadel, libcitadel_version_string,
+
+dnl Checks for the libical iCalendar library.
+AC_CHECK_HEADER(libical/ical.h,
+       [AC_CHECK_LIB(ical, icaltimezone_set_tzid_prefix,
                [
-                       LIBS="-lcitadel $LIBS"
+                       LIBS="-lical $LIBS"
                ],
                [
-                       AC_MSG_ERROR(libcitadel was not found or is not usable.  Please install libcitadel.)
+                       AC_MSG_ERROR(libical was not found and is required.  More info: http://www.citadel.org/doku.php/installation:start)
                ]
        ,
        )],
        [
-               AC_MSG_ERROR(libcitadel.h was not found or is not usable.  Please install libcitadel.)
+               AC_MSG_ERROR(libical/ical.h was not found and is required.  More info: http://www.citadel.org/doku.php/installation:start)
        ]
 )
 
 
-dnl Checks for the libical iCalendar library.
-AC_CHECK_HEADER(ical.h,
-       [AC_CHECK_LIB(ical, icalcomponent_new,
+dnl Check for libcitadel
+AC_CHECK_HEADER(libcitadel.h,
+       [AC_CHECK_LIB(citadel, libcitadel_version_string,
                [
-                       LIBS="-lical $LIBS"
+                       LIBS="-lcitadel $LIBS"
                ],
                [
-                       AC_MSG_ERROR(libical was not found and is required.  More info: http://www.citadel.org/doku.php/installation:start)
+                       AC_MSG_ERROR(libcitadel was not found or is not usable.  Please install libcitadel.)
                ]
        ,
        )],
        [
-               AC_MSG_ERROR(ical.h was not found and is required.  More info: http://www.citadel.org/doku.php/installation:start)
+               AC_MSG_ERROR(libcitadel.h was not found or is not usable.  Please install libcitadel.)
        ]
 )
 
 
-dnl Checks for the zlib compression library.
-if test "x$with_zlib" != xno ; then
-        AC_CHECK_HEADERS(zlib.h,
-                [AC_CHECK_LIB(z, zlibVersion,
-                        [ok_zlib=yes],,
-        )])
-fi
-
-if test "x$ok_zlib" = xyes ; then
-        LIBS="-lz $LIBS"
-        AC_DEFINE(HAVE_ZLIB,[],[whether we have zlib])
-fi
-
 
+found_ssl=no
 # The big search for OpenSSL
 if test "$with_ssl" != "no"; then
        saved_LIBS="$LIBS"
@@ -289,6 +279,7 @@ if test "$with_ssl" != "no"; then
        
        if test "x$ac_cv_openssldir" != "xno" ; then
                AC_DEFINE(HAVE_OPENSSL,[],[whethe we have openssl])
+               found_ssl=yes
                LIBS="-lssl -lcrypto $LIBS"
                dnl Need to recover ssldir - test above runs in subshell
                ssldir=$ac_cv_openssldir
@@ -324,6 +315,10 @@ AC_ARG_WITH(ssldir,
                        [ if test "x$withval" != "xno" ; then
                                              
                                                  ssl_dir="$withval"
+                                                 if test "$found_ssl" = "no"; then
+                                                    echo "Your setup was incomplete; ssldir doesn't make sense without openssl"
+                                                    exit
+                                                 fi
                          fi
                        AC_SUBST(MAKE_SSL_DIR)
                        ]
@@ -453,11 +448,11 @@ AC_ARG_WITH(editordir,
 )
 AC_DEFINE_UNQUOTED(EDITORDIR, "$editordir", [where to find our mail editor])
 
+./mk_module_init.sh
 AC_CONFIG_HEADER(sysdep.h)
 AC_OUTPUT(Makefile po/Makefile )
 
 echo ------------------------------------------------------------------------
-echo 'zlib compression:                ' $ok_zlib
 echo 'Character set conversion support:' $ok_iconv
 echo 'National language support:       ' $ok_nls
 echo