]> code.citadel.org Git - citadel.git/blobdiff - webcit/configure.ac
We now look for libical/ical.h instead of ical.h, because
[citadel.git] / webcit / configure.ac
index 2f7dc1fc979cb5daf5a8b02fd9481de17194e752..7ddfc1323d68bea333da46e0a882e010a9e8f38c 100644 (file)
@@ -1,6 +1,7 @@
 dnl Process this file with autoconf to produce a configure script.
 dnl $Id$
-AC_INIT([WebCit], [7.35], [http://www.citadel.org/])
+AC_INIT([WebCit], [7.37], [http://www.citadel.org/])
+
 
 AC_SUBST(PROG_SUBDIRS)
 AC_DEFINE(PROG_SUBDIRS, [], [Program dirs])
@@ -176,7 +177,7 @@ AC_CHECK_HEADER(libcitadel.h,
 
 
 dnl Checks for the libical iCalendar library.
-AC_CHECK_HEADER(ical.h,
+AC_CHECK_HEADER(libical/ical.h,
        [AC_CHECK_LIB(ical, icalcomponent_new,
                [
                        LIBS="-lical $LIBS"
@@ -187,7 +188,7 @@ AC_CHECK_HEADER(ical.h,
        ,
        )],
        [
-               AC_MSG_ERROR(ical.h was not found and is required.  More info: http://www.citadel.org/doku.php/installation:start)
+               AC_MSG_ERROR(libical/ical.h was not found and is required.  More info: http://www.citadel.org/doku.php/installation:start)
        ]
 )
 
@@ -452,6 +453,7 @@ AC_ARG_WITH(editordir,
 )
 AC_DEFINE_UNQUOTED(EDITORDIR, "$editordir", [where to find our mail editor])
 
+./mk_module_init.sh
 AC_CONFIG_HEADER(sysdep.h)
 AC_OUTPUT(Makefile po/Makefile )