Remove whitespace at end of canonicalized header lines
[citadel.git] / webcit / configure.ac
index eb3fd9ea5308f50ff972c40cc72cbd06011247e0..7ffaf142b725358974f64827c141f4055b5aae74 100644 (file)
@@ -1,7 +1,6 @@
 dnl Process this file with autoconf to produce a configure script.
 dnl $Id$
-AC_INIT([WebCit], [7.41], [http://www.citadel.org/])
-
+AC_INIT([WebCit],[m4_esyscmd_s(cat package-version.txt)],[http://uncensored.citadel.org])
 
 AC_SUBST(PROG_SUBDIRS)
 AC_DEFINE(PROG_SUBDIRS, [], [Program dirs])
@@ -12,7 +11,7 @@ AM_MISSING_PROG(AUTOCONF, autoconf, $missing_dir)
 AM_MISSING_PROG(ACLOCAL, aclocal, $missing_dir)
 
 dnl Make sure we see all GNU and Solaris extensions.
-AC_GNU_SOURCE
+AC_USE_SYSTEM_EXTENSIONS
 
 AC_CHECK_PROG(SED, sed, sed, no)
 AC_PREFIX_DEFAULT(/usr/local/webcit)
@@ -85,9 +84,42 @@ AC_SEARCH_LIBS(gethostbyname, nsl)
 AC_SEARCH_LIBS(connect, socket)
 
 dnl Checks for header files.
-AC_HEADER_STDC
+m4_warn([obsolete],
+[The preprocessor macro `STDC_HEADERS' is obsolete.
+  Except in unusual embedded environments, you can safely include all
+  ISO C90 headers unconditionally.])dnl
+# Autoupdate added the next two lines to ensure that your configure
+# script's behavior did not change.  They are probably safe to remove.
+AC_CHECK_INCLUDES_DEFAULT
+AC_PROG_EGREP
+
 dnl AC_HEADER_SYS_WAIT
 
+AC_CHECK_FUNCS(crypt gethostbyname connect flock getpwnam_r getpwuid_r getloadavg)
+AC_CACHE_CHECK(
+       [for call semantics from getpwuid_r], 
+       ac_cv_call_getpwuid_r,
+       [AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[#include <sys/types.h>
+#include <pwd.h>]], [[
+                               struct passwd pw, *pwp;
+                               char pwbuf[64];
+                               uid_t uid;
+
+                               getpwuid_r(uid, &pw, pwbuf, sizeof(pwbuf), &pwp);
+                       ]])],[ac_cv_call_getpwuid_r=yes],[ac_cv_call_getpwuid_r=no])
+       ])
+
+if test $ac_cv_call_getpwuid_r = no; then
+       AC_DEFINE(SOLARIS_GETPWUID,[],[do we need to use solaris call syntax?])
+       AC_DEFINE(SOLARIS_LOCALTIME_R,[], [do we need to use soralis call syntax?])
+       AC_DEFINE(F_UID_T, "%ld", [whats the matching format string for uid_t?])
+       AC_DEFINE(F_PID_T, "%ld",  [whats the matching format string for pid_t?])
+       AC_DEFINE(F_XPID_T, "%lx",  [whats the matching format string for xpid_t?])
+else
+       AC_DEFINE(F_UID_T, "%d",  [whats the matching format string for uid_t?])
+       AC_DEFINE(F_PID_T, "%d",  [whats the matching format string for pid_t?])
+       AC_DEFINE(F_XPID_T, "%x",  [whats the matching format string for xpid_t?])
+fi
 
 
 
@@ -95,26 +127,52 @@ dnl Checks for typedefs, structures, and compiler characteristics.
 AC_C_CONST
 AC_TYPE_OFF_T
 AC_TYPE_SIZE_T
-dnl AC_HEADER_TIME
+dnl Check the size of various builtin types; see typesize.h (error)
+AC_CHECK_SIZEOF(char, 0)
+AC_CHECK_SIZEOF(short, 0)
+AC_CHECK_SIZEOF(int, 0)
+AC_CHECK_SIZEOF(long, 0)
+AC_CHECK_SIZEOF(long unsigned int, 0)
+AC_CHECK_SIZEOF(size_t, 0)
 
 dnl Checks for library functions.
-AC_TYPE_SIGNAL
+m4_warn([obsolete],
+[your code may safely assume C89 semantics that RETSIGTYPE is void.
+Remove this warning and the `AC_CACHE_CHECK' when you adjust the code.])dnl
+AC_CACHE_CHECK([return type of signal handlers],[ac_cv_type_signal],[AC_COMPILE_IFELSE(
+[AC_LANG_PROGRAM([#include <sys/types.h>
+#include <signal.h>
+],
+                [return *(signal (0, 0)) (0) == 1;])],
+                  [ac_cv_type_signal=int],
+                  [ac_cv_type_signal=void])])
+AC_DEFINE_UNQUOTED([RETSIGTYPE],[$ac_cv_type_signal],[Define as the return type of signal handlers
+                   (`int' or `void').])
+
 dnl AC_FUNC_VPRINTF
 AC_REPLACE_FUNCS(snprintf)
-AC_CHECK_HEADERS(fcntl.h limits.h sys/time.h unistd.h iconv.h xlocale.h)
+AC_CHECK_HEADER(CUnit/CUnit.h, [AC_DEFINE(ENABLE_TESTS, [], [whether we should compile the test-suite])])
 
-dnl Checks for the zlib compression library.
-if test "x$with_zlib" != xno ; then
-       AC_CHECK_HEADERS(zlib.h,
-               [AC_CHECK_LIB(z, zlibVersion,
-                       [ok_zlib=yes],,
-       )])
-fi
+AC_CHECK_HEADERS(fcntl.h limits.h unistd.h iconv.h xlocale.h)
 
-if test "x$ok_zlib" = xyes ; then
-dnl  libcitadel will bring libz, so we don't need it here.     LDFLAGS="-lz $LDFLAGS" 
-       AC_DEFINE(HAVE_ZLIB, [], [define this if you have zlib compression available])
-fi
+dnl Checks for the zlib compression library.
+saved_CFLAGS="$CFLAGS"
+CFLAGS="$CFLAGS $SERVER_LIBS"
+AC_CHECK_HEADER(zlib.h,
+       [AC_CHECK_LIB(z, zlibVersion,
+               [
+                       LIBS="-lz $LIBS $SERVER_LIBS"
+               ],
+               [
+                       AC_MSG_ERROR(zlib was not found or is not usable.  Please install zlib.)
+               ]
+       ,
+       )],
+       [
+               AC_MSG_ERROR(zlib.h was not found or is not usable.  Please install zlib.)
+       ]
+)
+CFLAGS="$saved_CFLAGS"
 
 dnl Here is the check for a libc integrated iconv
 AC_ARG_ENABLE(iconv,
@@ -122,7 +180,7 @@ AC_ARG_ENABLE(iconv,
        ok_iconv=no, ok_iconv=yes)
 
 AC_MSG_CHECKING(Checking to see if your system supports iconv)
-AC_TRY_RUN([
+AC_RUN_IFELSE([AC_LANG_SOURCE([[
        #include <iconv.h>
        main() {
                iconv_t ic = (iconv_t)(-1) ;
@@ -130,46 +188,42 @@ AC_TRY_RUN([
                iconv_close(ic);
                exit(0);
        }
- ],
-               [
+ ]])],[
                  ok_iconv=yes
                  AC_MSG_RESULT([yes])
-               ],
-               [ 
+               ],[ 
                  ok_iconv=no
                  AC_MSG_RESULT([no])
-               ]
-)
+               
+],[])
 
 dnl Check for iconv in external libiconv
 if test "$ok_iconv" = no; then
        AC_MSG_CHECKING(Checking for an external libiconv)
        OLD_LDFLAGS="$LDFLAGS"
        LDFLAGS="$LDFLAGS -liconv"
-       AC_TRY_RUN([
+       AC_RUN_IFELSE([AC_LANG_SOURCE([[
                        #include <iconv.h>
                        main() {
                                iconv_t ic = (iconv_t)(-1) ;
                                ic = iconv_open("UTF-8", "us-ascii");
                                iconv_close(ic);
                        }
-               ],
-                       [
+               ]])],[
                          ok_iconv=yes
                          AC_MSG_RESULT([yes])
-                       ],
-                       [ 
+                       ],[ 
                          ok_iconv=no
                          LDFLAGS="$OLD_LDFLAGS"
                          AC_MSG_RESULT([no])
-                       ]
-               )
+                       
+               ],[])
 fi     
 if test "$ok_iconv" != "no"; then
-       AC_MSG_RESULT(WebCit will be built with character set conversion.)
+       AC_MSG_RESULT(webcit will be built with character set conversion.)
        AC_DEFINE(HAVE_ICONV,[],[whether we have iconv for charset conversion])
 else
-       AC_MSG_RESULT(WebCit will be built without character set conversion.)
+       AC_MSG_RESULT(webcit will be built without character set conversion.)
 fi
 
 AC_CHECK_LIB(intl, libintl_bindtextdomain, [LDFLAGS="$LDFLAGS -lintl"])
@@ -191,6 +245,13 @@ AC_CHECK_HEADER(libical/ical.h,
        ]
 )
 
+dnl Checks for the discount markdown library.
+AC_CHECK_LIB(markdown,
+        markdown,
+        [
+        LIBS="$LIBS -lmarkdown"
+        AC_DEFINE(HAVE_MARKDOWN,[],[whether we have markdown message rendering])
+])
 
 dnl Check for libcitadel
 AC_CHECK_HEADER(libcitadel.h,
@@ -209,6 +270,49 @@ AC_CHECK_HEADER(libcitadel.h,
        ]
 )
 
+AC_MSG_CHECKING([whether your system likes memcpy + HKEY]) 
+AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[
+#define _GNU_SOURCE
+#include <ctype.h>
+#include <errno.h>
+#include <string.h>
+#include <unistd.h>
+#include <string.h>
+#include <stdio.h>
+#include <sys/select.h>
+#include <fcntl.h>
+#include <sys/types.h>
+
+#include "lib/libcitadel.h"
+]], [[
+       char foo[22];
+       memcpy(foo, HKEY("foo"));
+       
+]])],[
+
+                 AC_MSG_RESULT([yes])
+               ],[ 
+                 AC_DEFINE(UNDEF_MEMCPY, [], [whether we need to undefine memcpy])
+                 AC_MSG_RESULT([no])
+               
+])
+
+dnl Checks for the Expat XML parser.
+AC_CHECK_HEADER(expat.h,
+       [AC_CHECK_LIB(expat, XML_ParserCreateNS,
+               [
+                       LIBS="-lexpat $LIBS"
+               ],
+               [
+                       AC_MSG_ERROR(The Expat XML parser was not found and is required.  More info: http://www.citadel.org/doku.php/installation:start)
+               ]
+       ,
+       )],
+       [
+               AC_MSG_ERROR(expat.h was not found and is required.  More info: http://www.citadel.org/doku.php/installation:start)
+       ]
+)
+
 
 
 found_ssl=no
@@ -255,8 +359,7 @@ if test "$with_ssl" != "no"; then
        
                        # Basic test to check for compatible version and correct linking
                        # *does not* test for RSA - that comes later.
-                       AC_TRY_RUN(
-                               [
+                       AC_RUN_IFELSE([AC_LANG_SOURCE([[
        #include <string.h>
        #include <openssl/rand.h>
        int main(void)
@@ -266,12 +369,11 @@ if test "$with_ssl" != "no"; then
                RAND_add(a, sizeof(a), sizeof(a));
                return(RAND_status() <= 0);
        }
-                               ],
-                               [
+                               ]])],[
                                        found_crypto=1
                                        break;
-                               ], []
-                       )
+                               ],[
+                       ],[])
        
                        if test ! -z "$found_crypto" ; then
                                break;
@@ -363,7 +465,7 @@ fi
 if test "$ok_nls" != "no"; then
        AC_MSG_RESULT(WebCit will be built with national language support.)
        AC_DEFINE(ENABLE_NLS, [], [whether we have NLS support])
-       PROG_SUBDIRS="$PROG_SUBDIRS po"
+       PROG_SUBDIRS="$PROG_SUBDIRS po/webcit/"
 else
        AC_MSG_RESULT(WebCit will be built without national language support.)
 fi
@@ -397,12 +499,14 @@ if test "$prefix" = NONE; then
        wwwdir=$ac_default_prefix
        rundir=$ac_default_prefix
        editordir=$ac_default_prefix/tiny_mce
+       etcdir=$ac_default_prefix
 else
        localedir=$prefix
        wwwdir=$prefix
        datadir=$prefix
        rundir=$prefix
        editordir=$prefix/tiny_mce
+       etcdir=$prefix
 fi
 
 dnl where to put the locale files
@@ -461,14 +565,47 @@ AC_ARG_WITH(editordir,
                          fi
                        ]
 )
-AC_DEFINE_UNQUOTED(EDITORDIR, "$editordir", [where to find our mail editor])
 
-./mk_module_init.sh
-AC_CONFIG_HEADER(sysdep.h)
-AC_OUTPUT(Makefile po/Makefile )
+dnl Checks where to find our configs
+AC_ARG_WITH(etcdir, 
+                   [  --with-etcdir             directory to read our configs],
+                       [ if test "x$withval" != "xno" ; then
+                               etcdir=$withval
+                         fi
+                       ]
+)
+AC_DEFINE_UNQUOTED(ETCDIR, "$etcdir", [where to find our configs])
+ETCDIR=$etcdir
+AC_SUBST(ETCDIR)
+
+abs_srcdir="`cd $srcdir && pwd`"
+abs_builddir="`pwd`"
+if test "$abs_srcdir" != "$abs_builddir"; then
+   CFLAGS="$CFLAGS -I $abs_builddir"
+fi
+AC_CONFIG_HEADERS([sysdep.h])
+AC_CONFIG_FILES([Makefile po/webcit/Makefile])
+AC_OUTPUT
+
+if test "$abs_srcdir" != "$abs_builddir"; then
+   ln -s $abs_srcdir/static $abs_builddir
+   ln -s $abs_srcdir/tiny_mce $abs_builddir
+   ln -s $abs_srcdir/*.h $abs_builddir
+   make mkdir-init
+   
+else
+dnl just run it on devel systems and if non vdir build.
+   if test -d .svn; then
+      ./mk_module_init.sh
+   fi
+fi
+
+if test -n "$srcdir"; then 
+   export srcdir=.
+fi
+
 
 echo ------------------------------------------------------------------------
 echo 'Character set conversion support:' $ok_iconv
 echo 'National language support:       ' $ok_nls
-echo 'Compression support:             ' $ok_zlib
 echo