final touches on dkim test harness
[citadel.git] / webcit / configure.ac
index f416227c66c238353b861e236fc94e66d0d18561..7ffaf142b725358974f64827c141f4055b5aae74 100644 (file)
@@ -1,6 +1,6 @@
 dnl Process this file with autoconf to produce a configure script.
 dnl $Id$
-AC_INIT([WebCit], [7.31], [http://www.citadel.org/])
+AC_INIT([WebCit],[m4_esyscmd_s(cat package-version.txt)],[http://uncensored.citadel.org])
 
 AC_SUBST(PROG_SUBDIRS)
 AC_DEFINE(PROG_SUBDIRS, [], [Program dirs])
@@ -11,7 +11,7 @@ AM_MISSING_PROG(AUTOCONF, autoconf, $missing_dir)
 AM_MISSING_PROG(ACLOCAL, aclocal, $missing_dir)
 
 dnl Make sure we see all GNU and Solaris extensions.
-AC_GNU_SOURCE
+AC_USE_SYSTEM_EXTENSIONS
 
 AC_CHECK_PROG(SED, sed, sed, no)
 AC_PREFIX_DEFAULT(/usr/local/webcit)
@@ -23,8 +23,6 @@ else
        ssl_dir="$prefix/keys"
 fi
 
-AC_ARG_WITH(with_libical, [  --with-libical          use libical calendaring library])
-AC_ARG_WITH(with_zlib,    [  --with-zlib             use zlib compression if present])
 AC_ARG_WITH(ssl,
        [  --with-ssl=PATH         Specify path to OpenSSL installation ],
        [
@@ -52,6 +50,8 @@ case "$host" in
        *-*-solaris*)
                PTHREAD_DEFS='-D_REENTRANT -D_PTHREADS'
        ;;
+       *-*-darwin*)
+               LIBS=-lintl
 esac
 AC_SUBST(PTHREAD_DEFS)
 
@@ -62,9 +62,11 @@ dnl Configure compiler flags for GCC
 if test "$GCC" = yes; then
        case "$host" in
                *-*-solaris*)
+dnl                    CFLAGS="$CFLAGS -Wall -Wno-char-subscripts --pedantic"
                        CFLAGS="$CFLAGS -Wall -Wno-char-subscripts"
                ;;
                *)
+dnl                    CFLAGS="$CFLAGS -Wall --pedantic"
                        CFLAGS="$CFLAGS -Wall"
                ;;
        esac
@@ -82,10 +84,42 @@ AC_SEARCH_LIBS(gethostbyname, nsl)
 AC_SEARCH_LIBS(connect, socket)
 
 dnl Checks for header files.
-AC_HEADER_STDC
+m4_warn([obsolete],
+[The preprocessor macro `STDC_HEADERS' is obsolete.
+  Except in unusual embedded environments, you can safely include all
+  ISO C90 headers unconditionally.])dnl
+# Autoupdate added the next two lines to ensure that your configure
+# script's behavior did not change.  They are probably safe to remove.
+AC_CHECK_INCLUDES_DEFAULT
+AC_PROG_EGREP
+
 dnl AC_HEADER_SYS_WAIT
-AC_CHECK_HEADERS(fcntl.h limits.h sys/time.h unistd.h)
 
+AC_CHECK_FUNCS(crypt gethostbyname connect flock getpwnam_r getpwuid_r getloadavg)
+AC_CACHE_CHECK(
+       [for call semantics from getpwuid_r], 
+       ac_cv_call_getpwuid_r,
+       [AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[#include <sys/types.h>
+#include <pwd.h>]], [[
+                               struct passwd pw, *pwp;
+                               char pwbuf[64];
+                               uid_t uid;
+
+                               getpwuid_r(uid, &pw, pwbuf, sizeof(pwbuf), &pwp);
+                       ]])],[ac_cv_call_getpwuid_r=yes],[ac_cv_call_getpwuid_r=no])
+       ])
+
+if test $ac_cv_call_getpwuid_r = no; then
+       AC_DEFINE(SOLARIS_GETPWUID,[],[do we need to use solaris call syntax?])
+       AC_DEFINE(SOLARIS_LOCALTIME_R,[], [do we need to use soralis call syntax?])
+       AC_DEFINE(F_UID_T, "%ld", [whats the matching format string for uid_t?])
+       AC_DEFINE(F_PID_T, "%ld",  [whats the matching format string for pid_t?])
+       AC_DEFINE(F_XPID_T, "%lx",  [whats the matching format string for xpid_t?])
+else
+       AC_DEFINE(F_UID_T, "%d",  [whats the matching format string for uid_t?])
+       AC_DEFINE(F_PID_T, "%d",  [whats the matching format string for pid_t?])
+       AC_DEFINE(F_XPID_T, "%x",  [whats the matching format string for xpid_t?])
+fi
 
 
 
@@ -93,87 +127,195 @@ dnl Checks for typedefs, structures, and compiler characteristics.
 AC_C_CONST
 AC_TYPE_OFF_T
 AC_TYPE_SIZE_T
-dnl AC_HEADER_TIME
+dnl Check the size of various builtin types; see typesize.h (error)
+AC_CHECK_SIZEOF(char, 0)
+AC_CHECK_SIZEOF(short, 0)
+AC_CHECK_SIZEOF(int, 0)
+AC_CHECK_SIZEOF(long, 0)
+AC_CHECK_SIZEOF(long unsigned int, 0)
+AC_CHECK_SIZEOF(size_t, 0)
 
 dnl Checks for library functions.
-AC_TYPE_SIGNAL
+m4_warn([obsolete],
+[your code may safely assume C89 semantics that RETSIGTYPE is void.
+Remove this warning and the `AC_CACHE_CHECK' when you adjust the code.])dnl
+AC_CACHE_CHECK([return type of signal handlers],[ac_cv_type_signal],[AC_COMPILE_IFELSE(
+[AC_LANG_PROGRAM([#include <sys/types.h>
+#include <signal.h>
+],
+                [return *(signal (0, 0)) (0) == 1;])],
+                  [ac_cv_type_signal=int],
+                  [ac_cv_type_signal=void])])
+AC_DEFINE_UNQUOTED([RETSIGTYPE],[$ac_cv_type_signal],[Define as the return type of signal handlers
+                   (`int' or `void').])
+
 dnl AC_FUNC_VPRINTF
 AC_REPLACE_FUNCS(snprintf)
+AC_CHECK_HEADER(CUnit/CUnit.h, [AC_DEFINE(ENABLE_TESTS, [], [whether we should compile the test-suite])])
 
+AC_CHECK_HEADERS(fcntl.h limits.h unistd.h iconv.h xlocale.h)
 
-dnl Check for libcitadel
-AC_CHECK_HEADER(libcitadel.h,
-       [AC_CHECK_LIB(citadel, libcitadel_version_string,
+dnl Checks for the zlib compression library.
+saved_CFLAGS="$CFLAGS"
+CFLAGS="$CFLAGS $SERVER_LIBS"
+AC_CHECK_HEADER(zlib.h,
+       [AC_CHECK_LIB(z, zlibVersion,
                [
-                       LIBS="-lcitadel $LIBS"
+                       LIBS="-lz $LIBS $SERVER_LIBS"
                ],
                [
-                       AC_MSG_ERROR(libcitadel was not found or is not usable.  Please install libcitadel.)
+                       AC_MSG_ERROR(zlib was not found or is not usable.  Please install zlib.)
                ]
        ,
        )],
        [
-               AC_MSG_ERROR(libcitadel.h was not found or is not usable.  Please install libcitadel.)
+               AC_MSG_ERROR(zlib.h was not found or is not usable.  Please install zlib.)
        ]
 )
+CFLAGS="$saved_CFLAGS"
+
+dnl Here is the check for a libc integrated iconv
+AC_ARG_ENABLE(iconv,
+       [  --disable-iconv         do not use iconv charset conversion],
+       ok_iconv=no, ok_iconv=yes)
 
+AC_MSG_CHECKING(Checking to see if your system supports iconv)
+AC_RUN_IFELSE([AC_LANG_SOURCE([[
+       #include <iconv.h>
+       main() {
+               iconv_t ic = (iconv_t)(-1) ;
+               ic = iconv_open("UTF-8", "us-ascii");
+               iconv_close(ic);
+               exit(0);
+       }
+ ]])],[
+                 ok_iconv=yes
+                 AC_MSG_RESULT([yes])
+               ],[ 
+                 ok_iconv=no
+                 AC_MSG_RESULT([no])
+               
+],[])
 
-webcit_with_calendar_service=no
-dnl Checks for the libical calendaring library.
-if test "x$with_libical" != xno ; then
-        AC_CHECK_HEADERS(ical.h,
-                [AC_CHECK_LIB(ical, icalcomponent_new,
-                        [ok_libical=yes],,
-        )])
+dnl Check for iconv in external libiconv
+if test "$ok_iconv" = no; then
+       AC_MSG_CHECKING(Checking for an external libiconv)
+       OLD_LDFLAGS="$LDFLAGS"
+       LDFLAGS="$LDFLAGS -liconv"
+       AC_RUN_IFELSE([AC_LANG_SOURCE([[
+                       #include <iconv.h>
+                       main() {
+                               iconv_t ic = (iconv_t)(-1) ;
+                               ic = iconv_open("UTF-8", "us-ascii");
+                               iconv_close(ic);
+                       }
+               ]])],[
+                         ok_iconv=yes
+                         AC_MSG_RESULT([yes])
+                       ],[ 
+                         ok_iconv=no
+                         LDFLAGS="$OLD_LDFLAGS"
+                         AC_MSG_RESULT([no])
+                       
+               ],[])
+fi     
+if test "$ok_iconv" != "no"; then
+       AC_MSG_RESULT(webcit will be built with character set conversion.)
+       AC_DEFINE(HAVE_ICONV,[],[whether we have iconv for charset conversion])
+else
+       AC_MSG_RESULT(webcit will be built without character set conversion.)
 fi
 
-if test "x$ok_libical" = xyes ; then
+AC_CHECK_LIB(intl, libintl_bindtextdomain, [LDFLAGS="$LDFLAGS -lintl"])
 
-       AC_TRY_RUN(
-               [
-#include <ical.h>
-main() {
-        int major, minor, v;
-        sscanf(ICAL_VERSION, "%d.%d", &major, &minor);
-        v = 100*major + minor;
-        printf("libical version: %i\n", v);
-        if (v >= 30) {
-                printf("This version is ok.\n");
-               return(0);
-       }
-       printf("libical 0.30 or newer required.\n");
-       printf("Citadel will be built without calendar support.\n");
-       return(1);
-}
-               ], 
+
+dnl Checks for the libical iCalendar library.
+AC_CHECK_HEADER(libical/ical.h,
+       [AC_CHECK_LIB(ical, icaltimezone_set_tzid_prefix,
                [
                        LIBS="-lical $LIBS"
-                       AC_DEFINE(HAVE_LIBICAL,[],[whether we have libical available])
-                       webcit_with_calendar_service=yes
+               ],
+               [
+                       AC_MSG_ERROR(libical was not found and is required.  More info: http://www.citadel.org/doku.php/installation:start)
                ]
-       )
-fi
-ok_libical=$webcit_with_calendar_service
+       ,
+       )],
+       [
+               AC_MSG_ERROR(libical/ical.h was not found and is required.  More info: http://www.citadel.org/doku.php/installation:start)
+       ]
+)
 
+dnl Checks for the discount markdown library.
+AC_CHECK_LIB(markdown,
+        markdown,
+        [
+        LIBS="$LIBS -lmarkdown"
+        AC_DEFINE(HAVE_MARKDOWN,[],[whether we have markdown message rendering])
+])
 
-if test "$webcit_with_calendar_service" == "yes"; then
-                       AC_DEFINE(WEBCIT_WITH_CALENDAR_SERVICE,[],[whether we can do with calendar.])
-fi
+dnl Check for libcitadel
+AC_CHECK_HEADER(libcitadel.h,
+       [AC_CHECK_LIB(citadel, libcitadel_version_string,
+               [
+                       LIBS="-lcitadel $LIBS"
+                       SETUP_LIBS="-lcitadel $SETUP_LIBS"
+               ],
+               [
+                       AC_MSG_ERROR(libcitadel was not found or is not usable.  Please install libcitadel.)
+               ]
+       ,
+       )],
+       [
+               AC_MSG_ERROR(libcitadel.h was not found or is not usable.  Please install libcitadel.)
+       ]
+)
 
-dnl Checks for the zlib compression library.
-if test "x$with_zlib" != xno ; then
-        AC_CHECK_HEADERS(zlib.h,
-                [AC_CHECK_LIB(z, zlibVersion,
-                        [ok_zlib=yes],,
-        )])
-fi
+AC_MSG_CHECKING([whether your system likes memcpy + HKEY]) 
+AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[
+#define _GNU_SOURCE
+#include <ctype.h>
+#include <errno.h>
+#include <string.h>
+#include <unistd.h>
+#include <string.h>
+#include <stdio.h>
+#include <sys/select.h>
+#include <fcntl.h>
+#include <sys/types.h>
+
+#include "lib/libcitadel.h"
+]], [[
+       char foo[22];
+       memcpy(foo, HKEY("foo"));
+       
+]])],[
+
+                 AC_MSG_RESULT([yes])
+               ],[ 
+                 AC_DEFINE(UNDEF_MEMCPY, [], [whether we need to undefine memcpy])
+                 AC_MSG_RESULT([no])
+               
+])
+
+dnl Checks for the Expat XML parser.
+AC_CHECK_HEADER(expat.h,
+       [AC_CHECK_LIB(expat, XML_ParserCreateNS,
+               [
+                       LIBS="-lexpat $LIBS"
+               ],
+               [
+                       AC_MSG_ERROR(The Expat XML parser was not found and is required.  More info: http://www.citadel.org/doku.php/installation:start)
+               ]
+       ,
+       )],
+       [
+               AC_MSG_ERROR(expat.h was not found and is required.  More info: http://www.citadel.org/doku.php/installation:start)
+       ]
+)
 
-if test "x$ok_zlib" = xyes ; then
-        LIBS="-lz $LIBS"
-        AC_DEFINE(HAVE_ZLIB,[],[whether we have zlib])
-fi
 
 
+found_ssl=no
 # The big search for OpenSSL
 if test "$with_ssl" != "no"; then
        saved_LIBS="$LIBS"
@@ -217,8 +359,7 @@ if test "$with_ssl" != "no"; then
        
                        # Basic test to check for compatible version and correct linking
                        # *does not* test for RSA - that comes later.
-                       AC_TRY_RUN(
-                               [
+                       AC_RUN_IFELSE([AC_LANG_SOURCE([[
        #include <string.h>
        #include <openssl/rand.h>
        int main(void)
@@ -228,12 +369,11 @@ if test "$with_ssl" != "no"; then
                RAND_add(a, sizeof(a), sizeof(a));
                return(RAND_status() <= 0);
        }
-                               ],
-                               [
+                               ]])],[
                                        found_crypto=1
                                        break;
-                               ], []
-                       )
+                               ],[
+                       ],[])
        
                        if test ! -z "$found_crypto" ; then
                                break;
@@ -256,6 +396,7 @@ if test "$with_ssl" != "no"; then
        
        if test "x$ac_cv_openssldir" != "xno" ; then
                AC_DEFINE(HAVE_OPENSSL,[],[whethe we have openssl])
+               found_ssl=yes
                LIBS="-lssl -lcrypto $LIBS"
                dnl Need to recover ssldir - test above runs in subshell
                ssldir=$ac_cv_openssldir
@@ -291,92 +432,21 @@ AC_ARG_WITH(ssldir,
                        [ if test "x$withval" != "xno" ; then
                                              
                                                  ssl_dir="$withval"
+                                                 if test "$found_ssl" = "no"; then
+                                                    echo "Your setup was incomplete; ssldir doesn't make sense without openssl"
+                                                    exit
+                                                 fi
                          fi
                        AC_SUBST(MAKE_SSL_DIR)
                        ]
 )
 AC_DEFINE_UNQUOTED(SSL_DIR, "$ssl_dir", [were should we put our keys?])
 
-dnl Here is the check for a usable iconv
 
-AC_ARG_ENABLE(iconv,
-       [  --disable-iconv         do not use iconv charset conversion],
-       ok_iconv=no, ok_iconv=yes)
 
-if test "$ok_nls" != "no"; then
-       AC_MSG_RESULT(Checking to see if your system supports iconv...)
-       AC_TRY_RUN([
-               #include <iconv.h>
-               main() {
-                       iconv_t ic = (iconv_t)(-1) ;
-                       ic = iconv_open("UTF-8", "us-ascii");
-                       iconv_close(ic);
-                       exit(0);
-               }
-       ],
-               ok_iconv=yes,
-               ok_iconv=no
-       )
-fi
 
-dnl Check for iconv in external libiconv
-if test "$ok_nls" != "no"; then
-       if test "$ok_nls" == "no" ; then
-               AC_MSG_RESULT(Checking for an external libiconv...)
-               AC_CHECK_HEADER(iconv.h,
-                       [
-                               AC_CHECK_LIB(iconv, iconv_open,
-                                       [
-                                               LIBS="-liconv $LIBS"
-                                               ok_iconv=yes
-                                       ]
-                               )
-                       ]
-               )
-       fi
-fi
-
-if test "$ok_iconv" != "no"; then
-       AC_MSG_RESULT(WebCit will be built with character set conversion.)
-       AC_DEFINE(HAVE_ICONV,[],[whether we have iconv for charset conversion])
-else
-       AC_MSG_RESULT(WebCit will be built without character set conversion.)
-fi
-
-
-
-dnl Here is the check for libintl etc.
 AC_CHECK_FUNCS(strftime_l uselocale gettext)
 
-AC_ARG_ENABLE(nls,
-       [  --disable-nls           do not use Native Language Support],
-       ok_nls=no, ok_nls=yes)
-
-if test "$ok_nls" != "no"; then
-       AC_MSG_RESULT(Checking for per-thread NLS support...)
-       AC_TRY_RUN([
-                #define _GNU_SOURCE
-                #include <libintl.h>
-                #include <locale.h>
-                #include <time.h>
-                main() {
-                        char *foo = NULL;
-                        char baz[32];
-                       struct tm *tm;
-                        uselocale(LC_GLOBAL_LOCALE);
-                        foo = gettext("bar");
-                       if (0) {
-                               strftime_l(baz, sizeof baz, "%c", tm, LC_GLOBAL_LOCALE);
-                       }
-                        exit(0);
-               }
-       ],
-               ok_uselocale=yes,
-               ok_uselocale=no
-       )
-       ok_nls=$ok_uselocale
-fi
-
 if test "$ok_nls" != "no"; then
        AC_CHECK_PROG(ok_xgettext, xgettext, yes, no)
        ok_nls=$ok_xgettext
@@ -395,7 +465,7 @@ fi
 if test "$ok_nls" != "no"; then
        AC_MSG_RESULT(WebCit will be built with national language support.)
        AC_DEFINE(ENABLE_NLS, [], [whether we have NLS support])
-       PROG_SUBDIRS="$PROG_SUBDIRS po"
+       PROG_SUBDIRS="$PROG_SUBDIRS po/webcit/"
 else
        AC_MSG_RESULT(WebCit will be built without national language support.)
 fi
@@ -429,12 +499,14 @@ if test "$prefix" = NONE; then
        wwwdir=$ac_default_prefix
        rundir=$ac_default_prefix
        editordir=$ac_default_prefix/tiny_mce
+       etcdir=$ac_default_prefix
 else
        localedir=$prefix
        wwwdir=$prefix
        datadir=$prefix
        rundir=$prefix
        editordir=$prefix/tiny_mce
+       etcdir=$prefix
 fi
 
 dnl where to put the locale files
@@ -493,14 +565,47 @@ AC_ARG_WITH(editordir,
                          fi
                        ]
 )
-AC_DEFINE_UNQUOTED(EDITORDIR, "$editordir", [where to find our mail editor])
 
-AC_CONFIG_HEADER(sysdep.h)
-AC_OUTPUT(Makefile po/Makefile )
+dnl Checks where to find our configs
+AC_ARG_WITH(etcdir, 
+                   [  --with-etcdir             directory to read our configs],
+                       [ if test "x$withval" != "xno" ; then
+                               etcdir=$withval
+                         fi
+                       ]
+)
+AC_DEFINE_UNQUOTED(ETCDIR, "$etcdir", [where to find our configs])
+ETCDIR=$etcdir
+AC_SUBST(ETCDIR)
+
+abs_srcdir="`cd $srcdir && pwd`"
+abs_builddir="`pwd`"
+if test "$abs_srcdir" != "$abs_builddir"; then
+   CFLAGS="$CFLAGS -I $abs_builddir"
+fi
+AC_CONFIG_HEADERS([sysdep.h])
+AC_CONFIG_FILES([Makefile po/webcit/Makefile])
+AC_OUTPUT
+
+if test "$abs_srcdir" != "$abs_builddir"; then
+   ln -s $abs_srcdir/static $abs_builddir
+   ln -s $abs_srcdir/tiny_mce $abs_builddir
+   ln -s $abs_srcdir/*.h $abs_builddir
+   make mkdir-init
+   
+else
+dnl just run it on devel systems and if non vdir build.
+   if test -d .svn; then
+      ./mk_module_init.sh
+   fi
+fi
+
+if test -n "$srcdir"; then 
+   export srcdir=.
+fi
+
 
 echo ------------------------------------------------------------------------
-echo 'zlib compression:                ' $ok_zlib
-echo 'Calendar support:                ' $ok_libical
 echo 'Character set conversion support:' $ok_iconv
 echo 'National language support:       ' $ok_nls
 echo