Quick hack to buildpackages, use "buildpackages version" to simply have it tell you...
[citadel.git] / webcit / configure.ac
index f17cc58195f42e728c41e9680846e0a04e80d863..ac631f331394e0eb3baa796cb49af93409aedec4 100644 (file)
@@ -1,6 +1,6 @@
 dnl Process this file with autoconf to produce a configure script.
 dnl $Id$
-AC_INIT([WebCit], [8.29], [http://www.citadel.org/])
+AC_INIT([WebCit], [902], [http://www.citadel.org/])
 
 
 AC_SUBST(PROG_SUBDIRS)
@@ -88,6 +88,7 @@ dnl Checks for header files.
 AC_HEADER_STDC
 dnl AC_HEADER_SYS_WAIT
 
+AC_CHECK_FUNCS(crypt gethostbyname connect flock getpwnam_r getpwuid_r getloadavg)
 AC_CACHE_CHECK(
        [for call semantics from getpwuid_r], 
        ac_cv_call_getpwuid_r,
@@ -238,7 +239,7 @@ dnl Checks for the discount markdown library.
 AC_CHECK_LIB(markdown,
         markdown,
         [
-        LDFLAGS="$LDFLAGS -lmarkdown"
+        LIBS="$LIBS -lmarkdown"
         AC_DEFINE(HAVE_MARKDOWN,[],[whether we have markdown message rendering])
 ])