push tags
[citadel.git] / webcit / configure.ac
index 6f3a7bc775ebfd4a6901e17da0984ff2a96a86c4..af630a7fcc8957bafff66df68ec9a9df5f2be698 100644 (file)
@@ -1,6 +1,6 @@
 dnl Process this file with autoconf to produce a configure script.
 dnl $Id$
-AC_INIT([WebCit], [8.10], [http://www.citadel.org/])
+AC_INIT([WebCit], [8.23], [http://www.citadel.org/])
 
 
 AC_SUBST(PROG_SUBDIRS)
@@ -252,6 +252,35 @@ AC_CHECK_HEADER(libcitadel.h,
        ]
 )
 
+AC_MSG_CHECKING([whether your system likes memcpy + HKEY]) 
+AC_TRY_COMPILE([
+#define _GNU_SOURCE
+#include <ctype.h>
+#include <errno.h>
+#include <string.h>
+#include <unistd.h>
+#include <string.h>
+#include <stdio.h>
+#include <sys/select.h>
+#include <fcntl.h>
+#include <sys/types.h>
+
+#include "lib/libcitadel.h"
+],
+[
+       char foo[22];
+       memcpy(foo, HKEY("foo"));
+       
+],
+               [
+
+                 AC_MSG_RESULT([yes])
+               ],
+               [ 
+                 AC_DEFINE(UNDEF_MEMCPY, [], [whether we need to undefine memcpy])
+                 AC_MSG_RESULT([no])
+               ]
+)
 
 dnl Checks for the Expat XML parser.
 AC_CHECK_HEADER(expat.h,