HUGE PATCH. This moves all of mime_parser.c and all
[citadel.git] / webcit / configure.ac
index 18dccdf75db0b83115ab9a5c1d9059e1cd38ad6a..d8c30e82d586008e26d8b4aab3a8a9ece4e5bc70 100644 (file)
@@ -1,14 +1,6 @@
 dnl Process this file with autoconf to produce a configure script.
 dnl $Id$
-AC_INIT(webserver.c)
-
-
-PACKAGE=webcit
-VERSION=7.22
-AC_DEFINE_UNQUOTED(PACKAGE, "$PACKAGE", [our package name])
-AC_DEFINE_UNQUOTED(VERSION, "$VERSION", [our package version])
-AC_SUBST(PACKAGE)
-AC_SUBST(VERSION)
+AC_INIT([WebCit], [7.24], [http://www.citadel.org/])
 
 AC_SUBST(PROG_SUBDIRS)
 AC_DEFINE(PROG_SUBDIRS, [], [Program dirs])
@@ -108,6 +100,25 @@ AC_TYPE_SIGNAL
 dnl AC_FUNC_VPRINTF
 AC_REPLACE_FUNCS(snprintf)
 
+
+dnl Check for libcitadel
+AC_CHECK_HEADER(libcitadel.h,
+       [AC_CHECK_LIB(citadel, libcitadel_version_string,
+               [
+                       AC_MSG_RESULT(OK)
+                       LIBS="-lcitadel $LIBS"
+               ],
+               [
+                       AC_MSG_ERROR(libcitadel was not found or is not usable.  Please install libcitadel.)
+               ]
+       ,
+       )],
+       [
+               AC_MSG_ERROR(libcitadel.h was not found or is not usable.  Please install libcitadel.)
+       ]
+)
+
+
 webcit_with_calendar_service=no
 dnl Checks for the libical calendaring library.
 if test "x$with_libical" != xno ; then