* Set version number to 7.50 across the entire system in preparation for upcoming...
[citadel.git] / webcit / configure.ac
index 61353f819e4904e229bcaf2f8f50f006cf369a0f..e36ab4a5dd3b9ebe28d82d4a4659e11e4a4259b3 100644 (file)
@@ -1,6 +1,6 @@
 dnl Process this file with autoconf to produce a configure script.
 dnl $Id$
-AC_INIT([WebCit], [7.37], [http://www.citadel.org/])
+AC_INIT([WebCit], [7.50], [http://www.citadel.org/])
 
 
 AC_SUBST(PROG_SUBDIRS)
@@ -63,10 +63,12 @@ dnl Configure compiler flags for GCC
 if test "$GCC" = yes; then
        case "$host" in
                *-*-solaris*)
-                       CFLAGS="$CFLAGS -Wall -Wno-char-subscripts --pedantic"
+dnl                    CFLAGS="$CFLAGS -Wall -Wno-char-subscripts --pedantic"
+                       CFLAGS="$CFLAGS -Wall -Wno-char-subscripts"
                ;;
                *)
-                       CFLAGS="$CFLAGS -Wall --pedantic"
+dnl                    CFLAGS="$CFLAGS -Wall --pedantic"
+                       CFLAGS="$CFLAGS -Wall"
                ;;
        esac
 fi
@@ -101,6 +103,18 @@ dnl AC_FUNC_VPRINTF
 AC_REPLACE_FUNCS(snprintf)
 AC_CHECK_HEADERS(fcntl.h limits.h sys/time.h unistd.h iconv.h xlocale.h)
 
+dnl Checks for the zlib compression library.
+if test "x$with_zlib" != xno ; then
+       AC_CHECK_HEADERS(zlib.h,
+               [AC_CHECK_LIB(z, zlibVersion,
+                       [ok_zlib=yes],,
+       )])
+fi
+
+if test "x$ok_zlib" = xyes ; then
+dnl  libcitadel will bring libz, so we don't need it here.     LDFLAGS="-lz $LDFLAGS" 
+       AC_DEFINE(HAVE_ZLIB, [], [define this if you have zlib compression available])
+fi
 
 dnl Here is the check for a libc integrated iconv
 AC_ARG_ENABLE(iconv,
@@ -456,4 +470,5 @@ AC_OUTPUT(Makefile po/Makefile )
 echo ------------------------------------------------------------------------
 echo 'Character set conversion support:' $ok_iconv
 echo 'National language support:       ' $ok_nls
+echo 'Compression support:             ' $ok_zlib
 echo