THIS IS 7.31
[citadel.git] / webcit / configure.ac
index b07cd2660dc647ee3fac5dac4387ab2524e63660..f416227c66c238353b861e236fc94e66d0d18561 100644 (file)
@@ -1,23 +1,27 @@
 dnl Process this file with autoconf to produce a configure script.
-dnl $Id: configure.in 4798 2006-12-28 16:34:20Z ajc $
-AC_INIT(webserver.c)
-
-
-PACKAGE=webcit
-VERSION=7.02
-AC_DEFINE_UNQUOTED(PACKAGE, "$PACKAGE")
-AC_DEFINE_UNQUOTED(VERSION, "$VERSION")
-AC_SUBST(PACKAGE)
-AC_SUBST(VERSION)
+dnl $Id$
+AC_INIT([WebCit], [7.31], [http://www.citadel.org/])
 
 AC_SUBST(PROG_SUBDIRS)
+AC_DEFINE(PROG_SUBDIRS, [], [Program dirs])
 AC_CANONICAL_HOST
 AC_PROG_INSTALL
 missing_dir=`cd $ac_aux_dir && pwd`
 AM_MISSING_PROG(AUTOCONF, autoconf, $missing_dir)
 AM_MISSING_PROG(ACLOCAL, aclocal, $missing_dir)
+
+dnl Make sure we see all GNU and Solaris extensions.
+AC_GNU_SOURCE
+
 AC_CHECK_PROG(SED, sed, sed, no)
 AC_PREFIX_DEFAULT(/usr/local/webcit)
+if test "$prefix" = NONE; then
+       AC_DEFINE_UNQUOTED(WEBCITDIR, "$ac_default_prefix", [define this to the Citadel home directory])
+       ssl_dir="$ac_default_prefix/keys"
+else
+       AC_DEFINE_UNQUOTED(WEBCITDIR, "$prefix", [define this to the Citadel home directory])
+       ssl_dir="$prefix/keys"
+fi
 
 AC_ARG_WITH(with_libical, [  --with-libical          use libical calendaring library])
 AC_ARG_WITH(with_zlib,    [  --with-zlib             use zlib compression if present])
@@ -94,9 +98,27 @@ dnl AC_HEADER_TIME
 dnl Checks for library functions.
 AC_TYPE_SIGNAL
 dnl AC_FUNC_VPRINTF
-dnl AC_CHECK_FUNCS(strerror)
 AC_REPLACE_FUNCS(snprintf)
 
+
+dnl Check for libcitadel
+AC_CHECK_HEADER(libcitadel.h,
+       [AC_CHECK_LIB(citadel, libcitadel_version_string,
+               [
+                       LIBS="-lcitadel $LIBS"
+               ],
+               [
+                       AC_MSG_ERROR(libcitadel was not found or is not usable.  Please install libcitadel.)
+               ]
+       ,
+       )],
+       [
+               AC_MSG_ERROR(libcitadel.h was not found or is not usable.  Please install libcitadel.)
+       ]
+)
+
+
+webcit_with_calendar_service=no
 dnl Checks for the libical calendaring library.
 if test "x$with_libical" != xno ; then
         AC_CHECK_HEADERS(ical.h,
@@ -115,23 +137,28 @@ main() {
         sscanf(ICAL_VERSION, "%d.%d", &major, &minor);
         v = 100*major + minor;
         printf("libical version: %i\n", v);
-        if (v >= 24) {
+        if (v >= 30) {
                 printf("This version is ok.\n");
                return(0);
        }
-       printf("libical 0.24 or newer required.\n");
+       printf("libical 0.30 or newer required.\n");
        printf("Citadel will be built without calendar support.\n");
        return(1);
 }
                ], 
                [
                        LIBS="-lical $LIBS"
-                       AC_DEFINE(HAVE_LIBICAL)
+                       AC_DEFINE(HAVE_LIBICAL,[],[whether we have libical available])
+                       webcit_with_calendar_service=yes
                ]
        )
 fi
+ok_libical=$webcit_with_calendar_service
 
 
+if test "$webcit_with_calendar_service" == "yes"; then
+                       AC_DEFINE(WEBCIT_WITH_CALENDAR_SERVICE,[],[whether we can do with calendar.])
+fi
 
 dnl Checks for the zlib compression library.
 if test "x$with_zlib" != xno ; then
@@ -143,9 +170,10 @@ fi
 
 if test "x$ok_zlib" = xyes ; then
         LIBS="-lz $LIBS"
-        AC_DEFINE(HAVE_ZLIB)
+        AC_DEFINE(HAVE_ZLIB,[],[whether we have zlib])
 fi
 
+
 # The big search for OpenSSL
 if test "$with_ssl" != "no"; then
        saved_LIBS="$LIBS"
@@ -227,7 +255,7 @@ if test "$with_ssl" != "no"; then
        CFLAGS="$saved_CFLAGS"
        
        if test "x$ac_cv_openssldir" != "xno" ; then
-               AC_DEFINE(HAVE_OPENSSL)
+               AC_DEFINE(HAVE_OPENSSL,[],[whethe we have openssl])
                LIBS="-lssl -lcrypto $LIBS"
                dnl Need to recover ssldir - test above runs in subshell
                ssldir=$ac_cv_openssldir
@@ -255,6 +283,19 @@ if test "$with_ssl" != "no"; then
                fi
        fi
 fi
+dnl Checks for the SSLdir
+dnl this is a bit different than the rest, 
+dnl because of the citadel used to have a keys/ subdir.
+AC_ARG_WITH(ssldir, 
+                   [  --with-ssldir          directory to store the ssl certificates under],
+                       [ if test "x$withval" != "xno" ; then
+                                             
+                                                 ssl_dir="$withval"
+                         fi
+                       AC_SUBST(MAKE_SSL_DIR)
+                       ]
+)
+AC_DEFINE_UNQUOTED(SSL_DIR, "$ssl_dir", [were should we put our keys?])
 
 dnl Here is the check for a usable iconv
 
@@ -278,9 +319,26 @@ if test "$ok_nls" != "no"; then
        )
 fi
 
+dnl Check for iconv in external libiconv
+if test "$ok_nls" != "no"; then
+       if test "$ok_nls" == "no" ; then
+               AC_MSG_RESULT(Checking for an external libiconv...)
+               AC_CHECK_HEADER(iconv.h,
+                       [
+                               AC_CHECK_LIB(iconv, iconv_open,
+                                       [
+                                               LIBS="-liconv $LIBS"
+                                               ok_iconv=yes
+                                       ]
+                               )
+                       ]
+               )
+       fi
+fi
+
 if test "$ok_iconv" != "no"; then
        AC_MSG_RESULT(WebCit will be built with character set conversion.)
-       AC_DEFINE(HAVE_ICONV)
+       AC_DEFINE(HAVE_ICONV,[],[whether we have iconv for charset conversion])
 else
        AC_MSG_RESULT(WebCit will be built without character set conversion.)
 fi
@@ -288,6 +346,7 @@ fi
 
 
 dnl Here is the check for libintl etc.
+AC_CHECK_FUNCS(strftime_l uselocale gettext)
 
 AC_ARG_ENABLE(nls,
        [  --disable-nls           do not use Native Language Support],
@@ -335,7 +394,7 @@ fi
 
 if test "$ok_nls" != "no"; then
        AC_MSG_RESULT(WebCit will be built with national language support.)
-       AC_DEFINE(ENABLE_NLS)
+       AC_DEFINE(ENABLE_NLS, [], [whether we have NLS support])
        PROG_SUBDIRS="$PROG_SUBDIRS po"
 else
        AC_MSG_RESULT(WebCit will be built without national language support.)
@@ -343,48 +402,100 @@ fi
 
 AC_SUBST(SETUP_LIBS)
 
+dnl disable backtrace if we don't want it.
+AC_ARG_WITH(gprof, 
+                   [  --with-gprof          enable profiling],
+                       [ if test "x$withval" != "xno" ; then
+                            CFLAGS="$CFLAGS  -pg "
+                            LDFLAGS="$LDFLAGS  -pg "
+                         fi
+                       ]
+)
+
+dnl disable backtrace if we don't want it.
+AC_ARG_WITH(backtrace, 
+                   [  --with-backtrace          enable backtrace dumps in the syslog],
+                       [ if test "x$withval" != "xno" ; then
+                            CFLAGS="$CFLAGS  -rdynamic "
+                            LDFLAGS="$LDFLAGS  -rdynamic "
+                             AC_CHECK_FUNCS(backtrace)
+                         fi
+                       ]
+)
 
 if test "$prefix" = NONE; then
-       LOCALEDIR=$ac_default_prefix
-       WWWDIR=$ac_default_prefix
-       EDITORDIR=$ac_default_prefix/tiny_mce
+       datadir=$ac_default_prefix
+       localedir=$ac_default_prefix
+       wwwdir=$ac_default_prefix
+       rundir=$ac_default_prefix
+       editordir=$ac_default_prefix/tiny_mce
 else
-       LOCALEDIR=$prefix
-       WWWDIR=$prefix
-       EDITORDIR=$prefix/tiny_mce
+       localedir=$prefix
+       wwwdir=$prefix
+       datadir=$prefix
+       rundir=$prefix
+       editordir=$prefix/tiny_mce
 fi
 
 dnl where to put the locale files
 AC_ARG_WITH(localedir, 
                    [  --with-localedir          directory to put the locale files to],
                        [ if test "x$withval" != "xno" ; then
-                                                 LOCALEDIR=$withval
+                           localedir=$withval
                          fi
                        ]
 )
+AC_DEFINE_UNQUOTED(LOCALEDIR, "$localedir",[where to find our pot files])
+LOCALEDIR=$localedir
 AC_SUBST(LOCALEDIR)
 
 dnl Checks where to put our templates
 AC_ARG_WITH(wwwdir, 
                    [  --with-wwwdir             directory to put our templates],
                        [ if test "x$withval" != "xno" ; then
-                                                 WWWDIR=$withval
+                               wwwdir=$withval
                          fi
                        ]
 )
+AC_DEFINE_UNQUOTED(WWWDIR, "$wwwdir", [where to find our templates and pics])
+WWWDIR=$wwwdir
 AC_SUBST(WWWDIR)
 
+
+dnl Checks for the run-dir for the sockets
+AC_ARG_WITH(rundir, 
+                       [  --with-rundir           directory to place runtime files (UDS) to?],
+                       [ if test "x$withval" != "xno" ; then
+                                           AC_DEFINE(HAVE_RUN_DIR, [], [should we put our non volatile files elsewhere?])
+                                               
+                                               rundir=$withval
+                                               AC_SUBST(MAKE_RUN_DIR)
+                         fi
+                       ]
+)
+AC_DEFINE_UNQUOTED(RUNDIR, "$rundir", [define, where the config should go in unix style])
+
+dnl Checks for the Datadir
+AC_ARG_WITH(datadir, 
+                   [  --with-datadir          directory to store the databases under],
+                       [ if test "x$withval" != "xno" ; then
+                                             datadir=$withval
+                         fi
+                       ]
+)
+AC_DEFINE_UNQUOTED(DATADIR, "$datadir",[define, if the user suplied a data-directory to use.])
+
 dnl Checks where to put our editor
 AC_ARG_WITH(editordir, 
                    [  --with-editordir             directory to put our editor],
                        [ if test "x$withval" != "xno" ; then
-                                                 EDITORDIR=$withval
+                               editordir=$withval
                          fi
                        ]
 )
-AC_SUBST(EDITORDIR)
-
+AC_DEFINE_UNQUOTED(EDITORDIR, "$editordir", [where to find our mail editor])
 
+AC_CONFIG_HEADER(sysdep.h)
 AC_OUTPUT(Makefile po/Makefile )
 
 echo ------------------------------------------------------------------------