fix source so that '-Wformat -Werror=format-security' doesn't stop us from compiling
[citadel.git] / webcit / debian / rules
index f97e5d04ebb25b4f843cd43fe856a8315b67aec4..2631d682c5347b9b8d8a0869b5f3c088d7d87f6e 100755 (executable)
@@ -18,6 +18,7 @@ DESTDIR=$(CURDIR)/debian/citadel-webcit
 EXTRA_ARGS=
 PROFILE_ARGS=
 COMPILER=
+CFLAGS= 
 #to enable debugging: export DEB_BUILD_OPTIONS="debug profiling compression urldebug iodbg clang"
 
 ifneq (,$(findstring clang,$(DEB_BUILD_OPTIONS)))
@@ -51,7 +52,7 @@ endif
 ifneq "$(wildcard /usr/share/misc/config.guess)" ""
        cp -f /usr/share/misc/config.guess config.guess
 endif
-       CC=$(COMPILER) CFLAGS="$(CFLAGS)" ./configure \
+       CC=$(COMPILER) CFLAGS=" -Wformat -Werror=format-security $(CFLAGS)" ./configure \
                --host=$(DEB_HOST_GNU_TYPE) \
                --build=$(DEB_BUILD_GNU_TYPE) \
                --prefix=/usr/sbin/ \