Finalize vcard editing:
[citadel.git] / webcit / debian / rules
index 1c5c346abf0e21970f96894d2f2d656f26ddb99e..46eecdca869c5cafa0136b225d36774eb46cd2ab 100755 (executable)
@@ -9,37 +9,62 @@
 # Uncomment this to turn on verbose mode.
 #export DH_VERBOSE=1
 
+include /usr/share/quilt/quilt.make
+
+upstreamversion := $(shell dpkg-parsechangelog | sed -n 's/^Version: *\([^-]\+\)-.\+/\1/p')
+
 DESTDIR=$(CURDIR)/debian/citadel-webcit
 
 EXTRA_ARGS=
 PROFILE_ARGS=
-#to enable debugging: export DEB_BUILD_OPTIONS="debug profiling"
+COMPILER=
+CFLAGS= 
+#to enable debugging: export DEB_BUILD_OPTIONS="debug profiling compression urldebug iodbg clang"
+
+ifneq (,$(findstring clang,$(DEB_BUILD_OPTIONS)))
+       COMPILER="clang" 
+endif
 ifneq (,$(findstring profiling,$(DEB_BUILD_OPTIONS)))
        PROFILE_ARGS= --with-gprof
+       LDFLAGS += -pg 
 endif
 ifneq (,$(findstring debug,$(DEB_BUILD_OPTIONS)))
-       CFLAGS += -O0 -ggdb -rdynamic -MD -MP 
-       LDFLAGS += -pg 
+       CFLAGS += -O0 -ggdb -rdynamic -MD -MP -D TECH_PREVIEW -pedantic -Wformat-nonliteral -Wmaybe-uninitialized -Wunused-variable
        EXTRA_ARGS =  --with-backtrace
 else
        CFLAGS += -O2
 endif
+ifneq (,$(findstring urldebug,$(DEB_BUILD_OPTIONS)))
+       CFLAGS += -D DEBUG_URLSTRINGS
+endif
+
+ifneq (,$(findstring iodbg,$(DEB_BUILD_OPTIONS)))
+       CFLAGS += -D SERV_TRACE
+endif
 
-configure: configure-stamp
+
+configure: patch configure-stamp
 configure-stamp:
        dh_testdir
-       CFLAGS="$(CFLAGS)" ./configure \
+ifneq "$(wildcard /usr/share/misc/config.sub)" ""
+       cp -f /usr/share/misc/config.sub config.sub
+endif
+ifneq "$(wildcard /usr/share/misc/config.guess)" ""
+       cp -f /usr/share/misc/config.guess config.guess
+endif
+       export CC=$(COMPILER); export CFLAGS=" -Wformat -Werror=format-security $(CFLAGS)"; ./configure \
                --host=$(DEB_HOST_GNU_TYPE) \
                --build=$(DEB_BUILD_GNU_TYPE) \
                --prefix=/usr/sbin/ \
                --with-wwwdir=/usr/share/citadel-webcit \
                --with-localedir=/usr/share/ \
-               --with-editordir=/usr/share/tinymce/www \
+               --with-editordir=/usr/share/tinymce/www/ \
+               --with-markdowneditordir=/usr/share/citadel-webcit/epic/ \
                --with-rundir=/var/run/citadel \
-               --with-ical --with-db --with-ldap \
                 --with-ssldir=/etc/ssl/webcit/ \
-               --with-zlib --with-ssl --with-libiconf \
-               --with-newt --with-included-gettext \
+               --with-etcdir=/etc/citadel \
+               --with-ssl \
+               --with-datadir=/var/run/citadel \
                --enable-debug $(EXTRA_ARGS) $(PROFILE_ARGS)
 
        touch configure-stamp
@@ -47,22 +72,22 @@ configure-stamp:
 
 build: build-stamp
 
-build-stamp: configure-stamp 
+build-stamp: configure-stamp
        dh_testdir
 
 # Add here commands to compile the package.
        $(MAKE)
-#docbook-to-man debian/webcit.sgml > webcit.1
 
        touch build-stamp
 
-clean:
+clean: configure-stamp
        dh_testdir
        dh_testroot
        rm -f build-stamp configure-stamp
 
 # Add here commands to clean up after the build process.
-       -$(MAKE) clean
+       [ ! -f Makefile ] || $(MAKE) clean
+       debconf-updatepo
 
        dh_clean 
 
@@ -71,7 +96,10 @@ install: build
        dh_testroot
        dh_clean -k 
        dh_installdirs
-       $(MAKE) install-bin install-locale install-wwwdata DESTDIR=$(DESTDIR)
+       $(MAKE) install-bin install-locale install-wwwdata install-cfg install-epic DESTDIR=$(DESTDIR)
+       chmod a-x -R $(DESTDIR)/usr/share/citadel-webcit/static/*
+       find $(DESTDIR)/usr/share/locale/ -name webcit.mo -exec chmod a-x {} \;
+       rm $(DESTDIR)/usr/share/citadel-webcit/static/prototype.js
 #      mkdir -p $(DESTDIR)/etc/citadel; cp webcit.conf $(DESTDIR)/etc/citadel/
 
 
@@ -84,27 +112,17 @@ binary-indep: build install
 binary-arch: build install
        dh_testdir
        dh_testroot
-#      dh_installchangelogs ChangeLog
+       dh_installchangelogs
        dh_installdocs
        dh_installexamples
        dh_install
-#      dh_installmenu
        dh_installdebconf       
-#      dh_installlogrotate
-#      dh_installemacsen
-#      dh_installpam
-#      dh_installmime
        dh_installinit --name=webcit
-#      dh_installcron
-#      dh_installinfo
        dh_installman
        dh_link
        dh_strip
        dh_compress
        dh_fixperms
-#      dh_perl
-#      dh_python
-#      dh_makeshlibs
        dh_installdeb
        dh_shlibdeps
        dh_gencontrol