Finalize vcard editing:
[citadel.git] / webcit / debian / rules
index a414b89bb6c129d0944ffa20c95bca38130660f5..46eecdca869c5cafa0136b225d36774eb46cd2ab 100755 (executable)
@@ -17,14 +17,19 @@ DESTDIR=$(CURDIR)/debian/citadel-webcit
 
 EXTRA_ARGS=
 PROFILE_ARGS=
-#to enable debugging: export DEB_BUILD_OPTIONS="debug profiling compression urldebug"
+COMPILER=
+CFLAGS= 
+#to enable debugging: export DEB_BUILD_OPTIONS="debug profiling compression urldebug iodbg clang"
 
+ifneq (,$(findstring clang,$(DEB_BUILD_OPTIONS)))
+       COMPILER="clang" 
+endif
 ifneq (,$(findstring profiling,$(DEB_BUILD_OPTIONS)))
        PROFILE_ARGS= --with-gprof
        LDFLAGS += -pg 
 endif
 ifneq (,$(findstring debug,$(DEB_BUILD_OPTIONS)))
-       CFLAGS += -O0 -ggdb -rdynamic -MD -MP -D TECH_PREVIEW -pedantic -Wformat-nonliteral
+       CFLAGS += -O0 -ggdb -rdynamic -MD -MP -D TECH_PREVIEW -pedantic -Wformat-nonliteral -Wmaybe-uninitialized -Wunused-variable
        EXTRA_ARGS =  --with-backtrace
 else
        CFLAGS += -O2
@@ -33,6 +38,11 @@ ifneq (,$(findstring urldebug,$(DEB_BUILD_OPTIONS)))
        CFLAGS += -D DEBUG_URLSTRINGS
 endif
 
+ifneq (,$(findstring iodbg,$(DEB_BUILD_OPTIONS)))
+       CFLAGS += -D SERV_TRACE
+endif
+
+
 configure: patch configure-stamp
 configure-stamp:
        dh_testdir
@@ -42,18 +52,18 @@ endif
 ifneq "$(wildcard /usr/share/misc/config.guess)" ""
        cp -f /usr/share/misc/config.guess config.guess
 endif
-       CFLAGS="$(CFLAGS)" ./configure \
+       export CC=$(COMPILER); export CFLAGS=" -Wformat -Werror=format-security $(CFLAGS)"; ./configure \
                --host=$(DEB_HOST_GNU_TYPE) \
                --build=$(DEB_BUILD_GNU_TYPE) \
                --prefix=/usr/sbin/ \
                --with-wwwdir=/usr/share/citadel-webcit \
                --with-localedir=/usr/share/ \
                --with-editordir=/usr/share/tinymce/www/ \
+               --with-markdowneditordir=/usr/share/citadel-webcit/epic/ \
                --with-rundir=/var/run/citadel \
-               --with-ical --with-db --with-ldap \
                 --with-ssldir=/etc/ssl/webcit/ \
-               --with-ssl --with-libiconf \
-               --with-newt --with-included-gettext \
+               --with-etcdir=/etc/citadel \
+               --with-ssl \
                --with-datadir=/var/run/citadel \
                --enable-debug $(EXTRA_ARGS) $(PROFILE_ARGS)
 
@@ -86,7 +96,7 @@ install: build
        dh_testroot
        dh_clean -k 
        dh_installdirs
-       $(MAKE) install-bin install-locale install-wwwdata DESTDIR=$(DESTDIR)
+       $(MAKE) install-bin install-locale install-wwwdata install-cfg install-epic DESTDIR=$(DESTDIR)
        chmod a-x -R $(DESTDIR)/usr/share/citadel-webcit/static/*
        find $(DESTDIR)/usr/share/locale/ -name webcit.mo -exec chmod a-x {} \;
        rm $(DESTDIR)/usr/share/citadel-webcit/static/prototype.js