Finalize vcard editing:
[citadel.git] / webcit / debian / rules
index cd0a58efb6ba21143fa8755eec7df37de41fbf46..46eecdca869c5cafa0136b225d36774eb46cd2ab 100755 (executable)
@@ -29,7 +29,7 @@ ifneq (,$(findstring profiling,$(DEB_BUILD_OPTIONS)))
        LDFLAGS += -pg 
 endif
 ifneq (,$(findstring debug,$(DEB_BUILD_OPTIONS)))
-       CFLAGS += -O0 -ggdb -rdynamic -MD -MP -D TECH_PREVIEW -pedantic -Wformat-nonliteral
+       CFLAGS += -O0 -ggdb -rdynamic -MD -MP -D TECH_PREVIEW -pedantic -Wformat-nonliteral -Wmaybe-uninitialized -Wunused-variable
        EXTRA_ARGS =  --with-backtrace
 else
        CFLAGS += -O2
@@ -59,8 +59,10 @@ endif
                --with-wwwdir=/usr/share/citadel-webcit \
                --with-localedir=/usr/share/ \
                --with-editordir=/usr/share/tinymce/www/ \
+               --with-markdowneditordir=/usr/share/citadel-webcit/epic/ \
                --with-rundir=/var/run/citadel \
                 --with-ssldir=/etc/ssl/webcit/ \
+               --with-etcdir=/etc/citadel \
                --with-ssl \
                --with-datadir=/var/run/citadel \
                --enable-debug $(EXTRA_ARGS) $(PROFILE_ARGS)
@@ -94,7 +96,7 @@ install: build
        dh_testroot
        dh_clean -k 
        dh_installdirs
-       $(MAKE) install-bin install-locale install-wwwdata DESTDIR=$(DESTDIR)
+       $(MAKE) install-bin install-locale install-wwwdata install-cfg install-epic DESTDIR=$(DESTDIR)
        chmod a-x -R $(DESTDIR)/usr/share/citadel-webcit/static/*
        find $(DESTDIR)/usr/share/locale/ -name webcit.mo -exec chmod a-x {} \;
        rm $(DESTDIR)/usr/share/citadel-webcit/static/prototype.js