Finalize vcard editing:
[citadel.git] / webcit / debian / rules
index f97e5d04ebb25b4f843cd43fe856a8315b67aec4..46eecdca869c5cafa0136b225d36774eb46cd2ab 100755 (executable)
@@ -18,6 +18,7 @@ DESTDIR=$(CURDIR)/debian/citadel-webcit
 EXTRA_ARGS=
 PROFILE_ARGS=
 COMPILER=
+CFLAGS= 
 #to enable debugging: export DEB_BUILD_OPTIONS="debug profiling compression urldebug iodbg clang"
 
 ifneq (,$(findstring clang,$(DEB_BUILD_OPTIONS)))
@@ -28,7 +29,7 @@ ifneq (,$(findstring profiling,$(DEB_BUILD_OPTIONS)))
        LDFLAGS += -pg 
 endif
 ifneq (,$(findstring debug,$(DEB_BUILD_OPTIONS)))
-       CFLAGS += -O0 -ggdb -rdynamic -MD -MP -D TECH_PREVIEW -pedantic -Wformat-nonliteral
+       CFLAGS += -O0 -ggdb -rdynamic -MD -MP -D TECH_PREVIEW -pedantic -Wformat-nonliteral -Wmaybe-uninitialized -Wunused-variable
        EXTRA_ARGS =  --with-backtrace
 else
        CFLAGS += -O2
@@ -51,15 +52,17 @@ endif
 ifneq "$(wildcard /usr/share/misc/config.guess)" ""
        cp -f /usr/share/misc/config.guess config.guess
 endif
-       CC=$(COMPILER) CFLAGS="$(CFLAGS)" ./configure \
+       export CC=$(COMPILER); export CFLAGS=" -Wformat -Werror=format-security $(CFLAGS)"; ./configure \
                --host=$(DEB_HOST_GNU_TYPE) \
                --build=$(DEB_BUILD_GNU_TYPE) \
                --prefix=/usr/sbin/ \
                --with-wwwdir=/usr/share/citadel-webcit \
                --with-localedir=/usr/share/ \
                --with-editordir=/usr/share/tinymce/www/ \
+               --with-markdowneditordir=/usr/share/citadel-webcit/epic/ \
                --with-rundir=/var/run/citadel \
                 --with-ssldir=/etc/ssl/webcit/ \
+               --with-etcdir=/etc/citadel \
                --with-ssl \
                --with-datadir=/var/run/citadel \
                --enable-debug $(EXTRA_ARGS) $(PROFILE_ARGS)
@@ -93,7 +96,7 @@ install: build
        dh_testroot
        dh_clean -k 
        dh_installdirs
-       $(MAKE) install-bin install-locale install-wwwdata DESTDIR=$(DESTDIR)
+       $(MAKE) install-bin install-locale install-wwwdata install-cfg install-epic DESTDIR=$(DESTDIR)
        chmod a-x -R $(DESTDIR)/usr/share/citadel-webcit/static/*
        find $(DESTDIR)/usr/share/locale/ -name webcit.mo -exec chmod a-x {} \;
        rm $(DESTDIR)/usr/share/citadel-webcit/static/prototype.js