* add way to build the debs with url debugging
[citadel.git] / webcit / debian / rules
index 992fd5296718ed565c8c48dc4919fbaa3e248d6d..649784d261320e15b82779fa46c1e791463e4ce6 100755 (executable)
@@ -13,7 +13,7 @@ DESTDIR=$(CURDIR)/debian/citadel-webcit
 
 EXTRA_ARGS=
 PROFILE_ARGS=
-#to enable debugging: export DEB_BUILD_OPTIONS="debug profiling compression"
+#to enable debugging: export DEB_BUILD_OPTIONS="debug profiling compression urldebug"
 
 
 ifneq (,$(findstring compression,$(DEB_BUILD_OPTIONS)))
@@ -31,6 +31,9 @@ ifneq (,$(findstring debug,$(DEB_BUILD_OPTIONS)))
 else
        CFLAGS += -O2
 endif
+ifneq (,$(findstring urldebug,$(DEB_BUILD_OPTIONS)))
+       CFLAGS += -D DEBUG_URLSTRINGS
+endif
 
 configure: configure-stamp
 configure-stamp: