* use the debian prototypejs package
[citadel.git] / webcit / debian / rules
index 1c5c346abf0e21970f96894d2f2d656f26ddb99e..992fd5296718ed565c8c48dc4919fbaa3e248d6d 100755 (executable)
@@ -13,12 +13,19 @@ DESTDIR=$(CURDIR)/debian/citadel-webcit
 
 EXTRA_ARGS=
 PROFILE_ARGS=
-#to enable debugging: export DEB_BUILD_OPTIONS="debug profiling"
+#to enable debugging: export DEB_BUILD_OPTIONS="debug profiling compression"
+
+
+ifneq (,$(findstring compression,$(DEB_BUILD_OPTIONS)))
+       ZLIB_ARGS=--without-zlib
+else
+       ZLIB_ARGS=--with-zlib
+endif
 ifneq (,$(findstring profiling,$(DEB_BUILD_OPTIONS)))
        PROFILE_ARGS= --with-gprof
 endif
 ifneq (,$(findstring debug,$(DEB_BUILD_OPTIONS)))
-       CFLAGS += -O0 -ggdb -rdynamic -MD -MP 
+       CFLAGS += -O0 -ggdb -rdynamic -MD -MP -D TECH_PREVIEW
        LDFLAGS += -pg 
        EXTRA_ARGS =  --with-backtrace
 else
@@ -38,8 +45,9 @@ configure-stamp:
                --with-rundir=/var/run/citadel \
                --with-ical --with-db --with-ldap \
                 --with-ssldir=/etc/ssl/webcit/ \
-               --with-zlib --with-ssl --with-libiconf \
+               $(ZLIB_ARGS) --with-ssl --with-libiconf \
                --with-newt --with-included-gettext \
+               --with-datadir=/var/run/citadel \
                --enable-debug $(EXTRA_ARGS) $(PROFILE_ARGS)
 
        touch configure-stamp
@@ -72,6 +80,7 @@ install: build
        dh_clean -k 
        dh_installdirs
        $(MAKE) install-bin install-locale install-wwwdata DESTDIR=$(DESTDIR)
+       rm $(DESTDIR)/usr/share/citadel-webcit/static/prototype.js
 #      mkdir -p $(DESTDIR)/etc/citadel; cp webcit.conf $(DESTDIR)/etc/citadel/
 
 
@@ -84,7 +93,7 @@ binary-indep: build install
 binary-arch: build install
        dh_testdir
        dh_testroot
-#      dh_installchangelogs ChangeLog
+       dh_installchangelogs
        dh_installdocs
        dh_installexamples
        dh_install