* fix a buffer overrun in case of bad strings in vcards.
[citadel.git] / webcit / debian / rules
index 0a62396a7ad18123328dc3c7ff7fa29a1a156ee6..a414b89bb6c129d0944ffa20c95bca38130660f5 100755 (executable)
@@ -24,7 +24,7 @@ ifneq (,$(findstring profiling,$(DEB_BUILD_OPTIONS)))
        LDFLAGS += -pg 
 endif
 ifneq (,$(findstring debug,$(DEB_BUILD_OPTIONS)))
-       CFLAGS += -O0 -ggdb -rdynamic -MD -MP -D TECH_PREVIEW -pedantic
+       CFLAGS += -O0 -ggdb -rdynamic -MD -MP -D TECH_PREVIEW -pedantic -Wformat-nonliteral
        EXTRA_ARGS =  --with-backtrace
 else
        CFLAGS += -O2