.debs: export the cflags
[citadel.git] / webcit / debian / rules
index 31541862deaa15df9a15e910fc04d9b3313cea0d..cd0a58efb6ba21143fa8755eec7df37de41fbf46 100755 (executable)
@@ -17,8 +17,13 @@ DESTDIR=$(CURDIR)/debian/citadel-webcit
 
 EXTRA_ARGS=
 PROFILE_ARGS=
-#to enable debugging: export DEB_BUILD_OPTIONS="debug profiling compression urldebug iodbg"
+COMPILER=
+CFLAGS= 
+#to enable debugging: export DEB_BUILD_OPTIONS="debug profiling compression urldebug iodbg clang"
 
+ifneq (,$(findstring clang,$(DEB_BUILD_OPTIONS)))
+       COMPILER="clang" 
+endif
 ifneq (,$(findstring profiling,$(DEB_BUILD_OPTIONS)))
        PROFILE_ARGS= --with-gprof
        LDFLAGS += -pg 
@@ -47,7 +52,7 @@ endif
 ifneq "$(wildcard /usr/share/misc/config.guess)" ""
        cp -f /usr/share/misc/config.guess config.guess
 endif
-       CFLAGS="$(CFLAGS)" ./configure \
+       export CC=$(COMPILER); export CFLAGS=" -Wformat -Werror=format-security $(CFLAGS)"; ./configure \
                --host=$(DEB_HOST_GNU_TYPE) \
                --build=$(DEB_BUILD_GNU_TYPE) \
                --prefix=/usr/sbin/ \