.debs: export the cflags
[citadel.git] / webcit / debian / rules
index a414b89bb6c129d0944ffa20c95bca38130660f5..cd0a58efb6ba21143fa8755eec7df37de41fbf46 100755 (executable)
@@ -17,8 +17,13 @@ DESTDIR=$(CURDIR)/debian/citadel-webcit
 
 EXTRA_ARGS=
 PROFILE_ARGS=
-#to enable debugging: export DEB_BUILD_OPTIONS="debug profiling compression urldebug"
+COMPILER=
+CFLAGS= 
+#to enable debugging: export DEB_BUILD_OPTIONS="debug profiling compression urldebug iodbg clang"
 
+ifneq (,$(findstring clang,$(DEB_BUILD_OPTIONS)))
+       COMPILER="clang" 
+endif
 ifneq (,$(findstring profiling,$(DEB_BUILD_OPTIONS)))
        PROFILE_ARGS= --with-gprof
        LDFLAGS += -pg 
@@ -33,6 +38,11 @@ ifneq (,$(findstring urldebug,$(DEB_BUILD_OPTIONS)))
        CFLAGS += -D DEBUG_URLSTRINGS
 endif
 
+ifneq (,$(findstring iodbg,$(DEB_BUILD_OPTIONS)))
+       CFLAGS += -D SERV_TRACE
+endif
+
+
 configure: patch configure-stamp
 configure-stamp:
        dh_testdir
@@ -42,7 +52,7 @@ endif
 ifneq "$(wildcard /usr/share/misc/config.guess)" ""
        cp -f /usr/share/misc/config.guess config.guess
 endif
-       CFLAGS="$(CFLAGS)" ./configure \
+       export CC=$(COMPILER); export CFLAGS=" -Wformat -Werror=format-security $(CFLAGS)"; ./configure \
                --host=$(DEB_HOST_GNU_TYPE) \
                --build=$(DEB_BUILD_GNU_TYPE) \
                --prefix=/usr/sbin/ \
@@ -50,10 +60,8 @@ endif
                --with-localedir=/usr/share/ \
                --with-editordir=/usr/share/tinymce/www/ \
                --with-rundir=/var/run/citadel \
-               --with-ical --with-db --with-ldap \
                 --with-ssldir=/etc/ssl/webcit/ \
-               --with-ssl --with-libiconf \
-               --with-newt --with-included-gettext \
+               --with-ssl \
                --with-datadir=/var/run/citadel \
                --enable-debug $(EXTRA_ARGS) $(PROFILE_ARGS)