]> code.citadel.org Git - citadel.git/blobdiff - webcit/debian/rules
* remove obsolete configure options
[citadel.git] / webcit / debian / rules
index 0a62396a7ad18123328dc3c7ff7fa29a1a156ee6..d145623e0d78869fde84760e0b3209d4301c6cb1 100755 (executable)
@@ -24,7 +24,7 @@ ifneq (,$(findstring profiling,$(DEB_BUILD_OPTIONS)))
        LDFLAGS += -pg 
 endif
 ifneq (,$(findstring debug,$(DEB_BUILD_OPTIONS)))
-       CFLAGS += -O0 -ggdb -rdynamic -MD -MP -D TECH_PREVIEW -pedantic
+       CFLAGS += -O0 -ggdb -rdynamic -MD -MP -D TECH_PREVIEW -pedantic -Wformat-nonliteral
        EXTRA_ARGS =  --with-backtrace
 else
        CFLAGS += -O2
@@ -50,10 +50,8 @@ endif
                --with-localedir=/usr/share/ \
                --with-editordir=/usr/share/tinymce/www/ \
                --with-rundir=/var/run/citadel \
-               --with-ical --with-db --with-ldap \
                 --with-ssldir=/etc/ssl/webcit/ \
-               --with-ssl --with-libiconf \
-               --with-newt --with-included-gettext \
+               --with-ssl \
                --with-datadir=/var/run/citadel \
                --enable-debug $(EXTRA_ARGS) $(PROFILE_ARGS)