* add possibility to chose clang via environment
[citadel.git] / webcit / debian / rules
index 31541862deaa15df9a15e910fc04d9b3313cea0d..f97e5d04ebb25b4f843cd43fe856a8315b67aec4 100755 (executable)
@@ -17,8 +17,12 @@ DESTDIR=$(CURDIR)/debian/citadel-webcit
 
 EXTRA_ARGS=
 PROFILE_ARGS=
-#to enable debugging: export DEB_BUILD_OPTIONS="debug profiling compression urldebug iodbg"
+COMPILER=
+#to enable debugging: export DEB_BUILD_OPTIONS="debug profiling compression urldebug iodbg clang"
 
+ifneq (,$(findstring clang,$(DEB_BUILD_OPTIONS)))
+       COMPILER="clang" 
+endif
 ifneq (,$(findstring profiling,$(DEB_BUILD_OPTIONS)))
        PROFILE_ARGS= --with-gprof
        LDFLAGS += -pg 
@@ -47,7 +51,7 @@ endif
 ifneq "$(wildcard /usr/share/misc/config.guess)" ""
        cp -f /usr/share/misc/config.guess config.guess
 endif
-       CFLAGS="$(CFLAGS)" ./configure \
+       CC=$(COMPILER) CFLAGS="$(CFLAGS)" ./configure \
                --host=$(DEB_HOST_GNU_TYPE) \
                --build=$(DEB_BUILD_GNU_TYPE) \
                --prefix=/usr/sbin/ \