]> code.citadel.org Git - citadel.git/blob - citadel/citadel.spec
fc90c13a4de1de92bb59a713df0f4740dca10697
[citadel.git] / citadel / citadel.spec
1 # $Id$
2 Summary: Citadel/UX, the flexible, powerful way to build online communities
3 Name: citadel
4 Version: 6.20
5 Release: 1
6 Copyright: GPL
7 Group: Applications/Communications
8 Source0: http://uncensored.citadel.org/pub/citadel/citadel-ux-%{PACKAGE_VERSION}.tar.gz
9 Buildroot: /var/tmp/citadel-%{PACKAGE_VERSION}-root
10 Icon: citux-64x64.xpm
11 Vendor: Citadel/UX Development Team
12 URL:  http://uncensored.citadel.org/citadel/
13 #Autoprov: false
14 ExcludeOS: hpux
15
16 %description
17 An advanced messaging system which can be used for BBS, groupware, and
18 online community applications.  It is multithreaded, client/server, database
19 driven, and accessible via a growing selection of front ends.
20
21 %prep
22 %setup -n citadel
23
24 %build
25 CFLAGS="$RPM_OPT_FLAGS" ./configure --with-pam
26 make
27
28 %install
29 rm -rf $RPM_BUILD_ROOT
30 mkdir -p $RPM_BUILD_ROOT/etc/pam.d
31 make root=$RPM_BUILD_ROOT install
32 touch $RPM_BUILD_ROOT/usr/local/citadel/.hushlogin
33
34 %clean
35 rm -rf "$RPM_BUILD_ROOT"
36
37 %package server
38 Summary: Citadel/UX, the flexible, powerful way to build online communities
39 Group: System Environment/Daemons
40 Requires: citadel-data
41 Obsoletes: citadel
42 Obsoletes: citadel-ux
43 Obsoletes: citadel-smtp
44 Obsoletes: citadel-pop3
45 Obsoletes: citadel-imap
46 Obsoletes: citadel-mrtg
47 Obsoletes: citadel-calendar
48 %description server
49 Citadel/UX is an advanced messaging system which can be used for BBS,
50 groupware, and online community applications.  It is multithreaded,
51 client/server, database driven, and accessible via a growing selection of
52 front ends.  Remember to run /usr/local/citadel/setup after installing or
53 upgrading this package.
54 %defattr(-,root,root)
55 %files server
56 /etc/pam.d/citadel
57 %doc docs/citadel.html
58 %dir /usr/local/citadel/bio
59 %dir /usr/local/citadel/bitbucket
60 %dir /usr/local/citadel/files
61 %dir /usr/local/citadel/images
62 %dir /usr/local/citadel/info
63 %dir /usr/local/citadel/userpics
64 /usr/local/citadel/aidepost
65 /usr/local/citadel/base64
66 %attr(4755,root,root) /usr/local/citadel/chkpwd
67 /usr/local/citadel/citmail
68 /usr/local/citadel/citserver
69 /usr/local/citadel/msgform
70 /usr/local/citadel/sendcommand
71 /usr/local/citadel/setup
72 /usr/local/citadel/stats
73 /usr/local/citadel/stress
74 /usr/local/citadel/userlist
75 /usr/local/citadel/utilsmenu
76 %pre server
77 # Add the "bbs" user
78 /usr/sbin/useradd -c "Citadel" -s /bin/false -r -d /usr/local/citadel \
79                 citadel 2> /dev/null || :
80 %post server
81 if [ -f /etc/inittab ]; then
82         if ! grep 'citserver' /etc/inittab > /dev/null; then
83                 echo "c1:2345:/usr/local/citadel/citserver -h/usr/local/citadel -x7 -llocal4" >> /etc/inittab
84         fi
85 fi
86 if [ -f /etc/services ]; then
87         if ! grep '^citadel' /etc/services > /dev/null; then
88                 echo "citadel           504/tcp         # citadel" >> /etc/services
89         fi
90 fi
91 cd /usr/local/citadel
92 /usr/local/citadel/setup -q
93 %postun server
94 if [ -f /etc/inittab ]; then
95         grep -v 'citserver' < /etc/inittab > /etc/inittab.new && \
96         mv -f /etc/inittab.new /etc/inittab
97         /sbin/init q
98 fi
99
100 %package data
101 Summary: Data files for the Citadel/UX messaging system.
102 Group: System Environment/Daemons
103 %description data
104 Default data files for the Citadel/UX messaging system.  These files are
105 required by the Citadel/UX server.
106 %defattr(-,root,root)
107 %files data
108 /usr/local/citadel/.hushlogin
109 #%dir /usr/local/citadel/netconfigs
110 %dir /usr/local/citadel/network
111 %dir /usr/local/citadel/network/spoolin
112 %dir /usr/local/citadel/network/spoolout
113 %dir /usr/local/citadel/network/systems
114 %config(noreplace) /usr/local/citadel/network/filterlist
115 %config(noreplace) /usr/local/citadel/network/mail.aliases
116 %config(noreplace) /usr/local/citadel/network/mailinglists
117 %config(noreplace) /usr/local/citadel/network/rnews.xref
118 %config(noreplace) /usr/local/citadel/public_clients
119 %config /usr/local/citadel/help/aide
120 %config /usr/local/citadel/help/software
121 %config /usr/local/citadel/help/floors
122 %config(noreplace) /usr/local/citadel/help/hours
123 %config /usr/local/citadel/help/intro
124 %config /usr/local/citadel/help/mail
125 %config /usr/local/citadel/help/network
126 %config /usr/local/citadel/help/nice
127 %config(noreplace) /usr/local/citadel/help/policy
128 %config /usr/local/citadel/help/summary
129 %config(noreplace) /usr/local/citadel/messages/changepw
130 %config /usr/local/citadel/messages/aideopt
131 %config(noreplace) /usr/local/citadel/messages/entermsg
132 %config /usr/local/citadel/messages/dotopt
133 %config /usr/local/citadel/messages/mainmenu
134 %config /usr/local/citadel/messages/entopt
135 %config(noreplace) /usr/local/citadel/messages/goodbye
136 %config(noreplace) /usr/local/citadel/messages/hello
137 %config /usr/local/citadel/messages/help
138 %config(noreplace) /usr/local/citadel/messages/register
139 %config(noreplace) /usr/local/citadel/messages/newuser
140 %config /usr/local/citadel/messages/readopt
141 %config(noreplace) /usr/local/citadel/messages/roomaccess
142 %config(noreplace) /usr/local/citadel/messages/unlisted
143 %post data
144 # Yes, this is supposed to be executed twice; as ? might not yet exist
145 # but we want it to be listed.  It's kludgey; sue me.
146 /bin/ls /usr/local/citadel/help > "/usr/local/citadel/help/?"
147 /bin/ls /usr/local/citadel/help > "/usr/local/citadel/help/?"
148
149 %package client
150 Summary: Client for the Citadel/UX messaging system
151 Group: Applications/Communications
152 %description client
153 This is the text client software for the Citadel/UX messaging system.
154 Install this software if you need to connect to a Citadel/UX server.
155 %defattr(-,root,root)
156 %files client
157 /usr/local/citadel/citadel
158 /usr/local/citadel/citadel.rc
159 /usr/local/citadel/whobbs
160 %post client
161 if [ -f /etc/services ]; then
162         if ! grep '^citadel' /etc/services > /dev/null; then
163                 echo "citadel           504/tcp         # citadel" >> /etc/services
164         fi
165 fi