* add outfunction to MSGS that just outputs ID|EUID
[citadel.git] / citadel / debian / rules
1 #!/usr/bin/make -f
2
3 # Uncomment this to turn on verbose mode.
4 #export DH_VERBOSE=1
5
6 # This has to be exported to make some magic below work.
7 DEB_HOST_GNU_TYPE   ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
8 DEB_BUILD_GNU_TYPE  ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
9
10 export DH_OPTIONS
11
12 DEB_DESTDIR = $(CURDIR)/debian/tmp
13
14 CFLAGS = -Wall -g
15
16
17 EXTRA_ARGS=
18 PROFILE_ARGS=
19 #to enable debugging: export DEB_BUILD_OPTIONS="debug profiling threadoff"
20 ifneq (,$(findstring profiling,$(DEB_BUILD_OPTIONS)))
21         PROFILE_ARGS= --with-gprof
22 endif
23 ifneq (,$(findstring debug,$(DEB_BUILD_OPTIONS)))
24         CFLAGS += -O0 -ggdb -rdynamic -D_GNU_SOURCE -MD -MP -D TECH_PREVIEW
25         LDFLAGS+=-Wl,--no-undefined -Wl,--as-needed
26         EXTRA_ARGS = --with-backtrace
27 else
28         LDFLAGS+=-Wl,--no-undefined -Wl,--as-needed
29         CFLAGS += -O2
30 endif
31
32 ifneq (,$(findstring threadoff,$(DEB_BUILD_OPTIONS)))
33         THREAD_ARGS=--without-threaded-client
34 else
35         THREAD_ARGS=
36 endif
37
38 configure: configure-stamp
39 configure-stamp:
40         dh_testdir
41
42         LDFLAGS="$(LDFLAGS)"; CFLAGS="$(CFLAGS)" ./configure \
43                 --prefix=/var/lib/citadel/ \
44                 --with-datadir=/var/lib/citadel/ \
45                 --with-helpdir=/usr/share/citadel-server/ \
46                 --with-staticdatadir=/etc/citadel/ \
47                 --with-spooldir=/var/spool/citadel/ \
48                 --with-sysconfdir=/etc/citadel/ \
49                 --with-rundir=/var/run/citadel/ \
50                 --with-docdir=/usr/share/doc/citadel-doc/ \
51                 --with-ssldir=/etc/ssl/citadel/ \
52                 --with-utility-bindir=/usr/lib/citadel-server/ \
53                 --with-autosysconfdir=/var/lib/citadel/data/ \
54                 --with-pam \
55                 --with-db \
56                 --enable-debug $(EXTRA_ARGS) $(PROFILE_ARGS) $(THREAD_ARGS)
57
58         touch configure-stamp
59
60 #Architecture 
61 build: build-arch build-indep
62
63 build-arch: build-arch-stamp
64 build-arch-stamp: configure-stamp
65
66         $(MAKE)
67         touch $@
68
69 build-indep: build-indep-stamp
70 build-indep-stamp: configure-stamp
71
72         touch $@
73
74 clean:
75         dh_testdir
76         dh_testroot
77         rm -f build-arch-stamp build-indep-stamp configure-stamp
78
79         [ ! -f Makefile ] || $(MAKE) distclean
80
81         dh_clean 
82         rm -f config.status config.log
83
84 install: install-indep install-arch
85 install-indep: build-indep
86         dh_testdir
87         dh_testroot
88         dh_clean -k -i 
89         dh_installdirs -i
90
91         $(MAKE) DESTDIR=$(DEB_DESTDIR) install-doc-new
92
93         dh_install -i --sourcedir=debian/tmp
94
95 install-arch: build-arch
96         dh_testdir
97         dh_testroot
98         dh_clean -k -s 
99         dh_installdirs -s
100
101         $(MAKE) DESTDIR=$(DEB_DESTDIR) install-exec-new install-data-new
102
103         install -D -p -m0755 database_cleanup.sh \
104                 $(DEB_DESTDIR)/usr/share/doc/citadel-server/examples/database_cleanup.sh
105
106         install -D -p -m0644 docs/welcomemail.html \
107                 $(DEB_DESTDIR)/usr/share/doc/citadel-server/welcomemail.html
108
109         install -D -p -m0644 docs/welcomemail.txt \
110                 $(DEB_DESTDIR)/usr/share/doc/citadel-server/welcomemail.txt
111
112         dh_install -s --sourcedir=debian/tmp
113
114 binary-common:
115         dh_testdir
116         dh_testroot
117         dh_installchangelogs
118         dh_installdocs
119         dh_installdebconf       
120         dh_installinit --name=citadel
121         dh_installman
122         dh_strip --dbg-package=citadel-dbg
123         dh_link
124         dh_compress 
125         dh_fixperms
126         dh_makeshlibs
127         dh_installdeb
128         dh_shlibdeps
129         dh_gencontrol
130         dh_md5sums
131         dh_builddeb
132
133 # Build architecture independant packages using the common target.
134 binary-indep: build-indep install-indep
135         $(MAKE) -f debian/rules DH_OPTIONS=-i binary-common
136
137 # Build architecture dependant packages using the common target.
138 binary-arch: build-arch install-arch
139         $(MAKE) -f debian/rules DH_OPTIONS=-s binary-common
140
141 binary: binary-arch binary-indep
142 .PHONY: build clean binary-indep binary-arch binary install install-indep install-arch configure