* depend on bdb 4.3 or 4.4
[citadel.git] / citadel / debian / rules
1 #!/usr/bin/make -f
2 # -*- makefile -*-
3 # Sample debian/rules that uses debhelper.
4 #
5 # This file was originally written by Joey Hess and Craig Small.
6 # As a special exception, when this file is copied by dh-make into a
7 # dh-make output file, you may use that output file without restriction.
8 # This special exception was added by Craig Small in version 0.37 of dh-make.
9 #
10 # Modified to make a template file for a multi-binary package with separated
11 # build-arch and build-indep targets  by Bill Allombert 2001
12
13 # Uncomment this to turn on verbose mode.
14 #export DH_VERBOSE=1
15
16 # This has to be exported to make some magic below work.
17 export DH_OPTIONS
18
19 # These are used for cross-compiling and for saving the configure script
20 # from having to guess our platform (since we know it already)
21 DEB_HOST_GNU_TYPE   ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
22 DEB_BUILD_GNU_TYPE  ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
23 export VERSION=`grep 'THIS IS' $(CURDIR)/ChangeLog  |head -n 1 |sed "s;.* ;;"`
24
25 CFLAGS = -Wall -g
26
27 #ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
28         CFLAGS += -O0 -ggdb
29 #else
30 #       CFLAGS += -O2
31 #endif
32
33 config.status: configure
34         dh_testdir
35         CFLAGS="$(CFLAGS)" ./configure \
36                 --host=$(DEB_HOST_GNU_TYPE) \
37                 --build=$(DEB_BUILD_GNU_TYPE) \
38                 --prefix=/usr/sbin \
39                 --with-sysconfdir=/etc/citadel \
40                 --with-spooldir=/var/spool/citadel \
41                 --with-datadir=/var/lib/citadel \
42                 --with-rundir=/var/run/citadel \
43                 --with-docdir=/usr/share/doc/citadel-doc/ \
44                 --with-pam \
45                 --with-ical \
46                 --with-db \
47                 --with-ldap
48
49
50 #Architecture 
51 build: build-arch build-indep
52
53 build-arch: build-arch-stamp
54 build-arch-stamp:  config.status
55
56         # Add here commands to compile the arch part of the package.
57         #$(MAKE) 
58         touch build-arch-stamp
59
60 build-indep: build-indep-stamp
61 build-indep-stamp:  config.status
62
63         # Add here commands to compile the indep part of the package.
64         #$(MAKE) doc
65         touch build-indep-stamp
66
67 clean:
68         dh_testdir
69         dh_testroot
70         rm -f build-arch-stamp build-indep-stamp #CONFIGURE-STAMP#
71         -$(MAKE) distclean
72 ifneq "$(wildcard /usr/share/misc/config.sub)" ""
73         cp -f /usr/share/misc/config.sub config.sub
74 endif
75 ifneq "$(wildcard /usr/share/misc/config.guess)" ""
76         cp -f /usr/share/misc/config.guess config.guess
77 endif
78
79
80         dh_clean 
81
82 install: install-indep install-arch
83 install-indep:
84         dh_testdir
85         dh_testroot
86         dh_clean -k -i 
87         dh_installdirs -i
88         export root=$(CURDIR)/debian/tmp; $(MAKE) install-doc-new prefix=$(CURDIR)/debian/citadel-doc/
89
90
91 install-arch:
92         dh_testdir
93         dh_testroot
94         dh_clean -k -s 
95         dh_installdirs -s
96         mkdir -p  $(CURDIR)/debian/tmp/
97         export root=$(CURDIR)/debian/tmp/;$(MAKE) install-exec-new install-data-new
98
99         mkdir -p $(CURDIR)/debian/tmp/usr/lib/citadel-server
100         mv \
101                 $(CURDIR)/debian/tmp/usr/sbin/setup \
102                 $(CURDIR)/debian/tmp/usr/lib/citadel-server/
103         mv \
104                 $(CURDIR)/debian/tmp/usr/sbin/ctdlsvc \
105                 $(CURDIR)/debian/tmp/usr/lib/citadel-server/
106 #       cd $(CURDIR)/debian/tmp/usr/share/doc/citadel-server/examples/help; md5sum * >../help.md5sums
107 #       cd $(CURDIR)/debian/tmp/usr/share/doc/citadel-server/examples/messages; md5sum * >../messages.md5sums
108         cp \
109                 $(CURDIR)/debian/tmp/usr/sbin/citmail \
110                 $(CURDIR)/debian/tmp/usr/sbin/sendmail
111         dh_installexamples  
112         dh_install 
113 # Must not depend on anything. This is to be called by
114 # binary-arch/binary-indep
115 # in another 'make' thread.
116 binary-common:
117         dh_testdir
118         dh_testroot
119         dh_installchangelogs ChangeLog
120         dh_installdocs
121         dh_installexamples
122 #       dh_installmenu
123         dh_installdebconf       
124 #       dh_installlogrotate     
125 #       dh_installemacsen
126 #       dh_installpam
127 #       dh_installmime
128         dh_installinit  --name=citadel
129 #       dh_installcron
130 #       dh_installinfo
131         dh_installman
132 #doesn't work like that. will be done by postinst.
133 #       mkdir -p $(CURDIR)/debian/citadel-mta/usr/sbin
134 #       dh_link --package=citadel-mta /usr/sbin/citmail /usr/sbin/sendmail
135         dh_strip
136         dh_compress 
137         dh_fixperms
138 #       dh_perl
139 #       dh_python
140         dh_makeshlibs
141         dh_installdeb
142         dh_shlibdeps
143         dh_gencontrol
144         dh_md5sums
145         dh_builddeb
146 # Build architecture independant packages using the common target.
147 binary-indep: build-indep install-indep
148         $(MAKE) -f debian/rules DH_OPTIONS=-i binary-common
149
150 # Build architecture dependant packages using the common target.
151 binary-arch: build-arch install-arch
152         $(MAKE) -f debian/rules DH_OPTIONS=-a binary-common
153
154 binary: binary-arch binary-indep
155 .PHONY: build clean binary-indep binary-arch binary install install-indep install-arch