* add iodbg switch to debian scripts
[citadel.git] / citadel / debian / rules
1 #!/usr/bin/make -f
2
3 # Uncomment this to turn on verbose mode.
4 #export DH_VERBOSE=1
5
6 # This has to be exported to make some magic below work.
7 DEB_HOST_GNU_TYPE   ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
8 DEB_BUILD_GNU_TYPE  ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
9
10 export DH_OPTIONS
11
12 DEB_DESTDIR = $(CURDIR)/debian/tmp
13
14 CFLAGS = -Wall -g
15
16
17 EXTRA_ARGS=
18 PROFILE_ARGS=
19 #to enable debugging: export DEB_BUILD_OPTIONS="debug profiling threadoff"
20 ifneq (,$(findstring profiling,$(DEB_BUILD_OPTIONS)))
21         PROFILE_ARGS= --with-gprof
22 endif
23 ifneq (,$(findstring debug,$(DEB_BUILD_OPTIONS)))
24         CFLAGS += -O0 -ggdb -rdynamic -D_GNU_SOURCE -MD -MP -D TECH_PREVIEW
25         LDFLAGS+=-Wl,--no-undefined -Wl,--as-needed
26         EXTRA_ARGS = --with-backtrace
27 else
28         LDFLAGS+=-Wl,--no-undefined -Wl,--as-needed
29         CFLAGS += -O2
30 endif
31
32 ifneq (,$(findstring threadoff,$(DEB_BUILD_OPTIONS)))
33         THREAD_ARGS=--without-threaded-client
34 else
35         THREAD_ARGS=
36 endif
37
38
39 ifneq (,$(findstring iodbg,$(DEB_BUILD_OPTIONS)))
40         CFLAGS += -D BIGBAD_IODBG
41 endif
42
43 configure: configure-stamp
44 configure-stamp:
45         dh_testdir
46
47         LDFLAGS="$(LDFLAGS)"; CFLAGS="$(CFLAGS)" ./configure \
48                 --prefix=/var/lib/citadel/ \
49                 --with-datadir=/var/lib/citadel/ \
50                 --with-helpdir=/usr/share/citadel-server/ \
51                 --with-staticdatadir=/etc/citadel/ \
52                 --with-spooldir=/var/spool/citadel/ \
53                 --with-sysconfdir=/etc/citadel/ \
54                 --with-rundir=/var/run/citadel/ \
55                 --with-docdir=/usr/share/doc/citadel-doc/ \
56                 --with-ssldir=/etc/ssl/citadel/ \
57                 --with-utility-bindir=/usr/lib/citadel-server/ \
58                 --with-autosysconfdir=/var/lib/citadel/data/ \
59                 --with-pam \
60                 --with-db \
61                 --enable-debug $(EXTRA_ARGS) $(PROFILE_ARGS) $(THREAD_ARGS)
62
63         touch configure-stamp
64
65 #Architecture 
66 build: build-arch build-indep
67
68 build-arch: build-arch-stamp
69 build-arch-stamp: configure-stamp
70
71         $(MAKE)
72         touch $@
73
74 build-indep: build-indep-stamp
75 build-indep-stamp: configure-stamp
76
77         touch $@
78
79 clean:
80         dh_testdir
81         dh_testroot
82         rm -f build-arch-stamp build-indep-stamp configure-stamp
83
84
85         dh_clean 
86         rm -f config.status config.log
87 #[ ! -f Makefile ] || $(MAKE) distclean
88
89 install: install-indep install-arch
90 install-indep: build-indep
91         dh_testdir
92         dh_testroot
93         dh_clean -k -i 
94         dh_installdirs -i
95
96         $(MAKE) DESTDIR=$(DEB_DESTDIR) install-doc-new
97
98         dh_install -i --sourcedir=debian/tmp
99
100 install-arch: build-arch
101         dh_testdir
102         dh_testroot
103         dh_clean -k -s 
104         dh_installdirs -s
105
106         $(MAKE) DESTDIR=$(DEB_DESTDIR) install-exec-new install-data-new
107
108         install -D -p -m0755 database_cleanup.sh \
109                 $(DEB_DESTDIR)/usr/share/doc/citadel-server/examples/database_cleanup.sh
110
111         install -D -p -m0644 docs/welcomemail.html \
112                 $(DEB_DESTDIR)/usr/share/doc/citadel-server/welcomemail.html
113
114         install -D -p -m0644 docs/welcomemail.txt \
115                 $(DEB_DESTDIR)/usr/share/doc/citadel-server/welcomemail.txt
116
117         dh_install -s --sourcedir=debian/tmp
118
119 binary-common:
120         dh_testdir
121         dh_testroot
122         dh_installchangelogs
123         dh_installdocs
124         dh_installdebconf       
125         dh_installinit --name=citadel
126         dh_installman
127         dh_strip --dbg-package=citadel-dbg
128         dh_link
129         dh_compress 
130         dh_fixperms
131         dh_makeshlibs
132         dh_installdeb
133         dh_shlibdeps
134         dh_gencontrol
135         dh_md5sums
136         dh_builddeb
137
138 # Build architecture independant packages using the common target.
139 binary-indep: build-indep install-indep
140         $(MAKE) -f debian/rules DH_OPTIONS=-i binary-common
141
142 # Build architecture dependant packages using the common target.
143 binary-arch: build-arch install-arch
144         $(MAKE) -f debian/rules DH_OPTIONS=-s binary-common
145
146 binary: binary-arch binary-indep
147 .PHONY: build clean binary-indep binary-arch binary install install-indep install-arch configure