* profiling and debug switches here too.
[citadel.git] / webcit / debian / rules
1 #!/usr/bin/make -f
2 # -*- makefile -*-
3 # Sample debian/rules that uses debhelper.
4 # This file was originally written by Joey Hess and Craig Small.
5 # As a special exception, when this file is copied by dh-make into a
6 # dh-make output file, you may use that output file without restriction.
7 # This special exception was added by Craig Small in version 0.37 of dh-make.
8
9 # Uncomment this to turn on verbose mode.
10 #export DH_VERBOSE=1
11
12 DESTDIR=$(CURDIR)/debian/citadel-webcit
13
14 EXTRA_ARGS=
15 PROFILE_ARGS=
16 #to enable debugging: export DEB_BUILD_OPTIONS="debug profiling"
17 ifneq (,$(findstring profiling,$(DEB_BUILD_OPTIONS)))
18         PROFILE_ARGS= --with-gprof
19 endif
20 ifneq (,$(findstring debug,$(DEB_BUILD_OPTIONS)))
21         CFLAGS += -O0 -ggdb -rdynamic -D_GNU_SOURCE -MD -MP 
22         LDFLAGS += -pg 
23         EXTRA_ARGS =  --with-backtrace
24 else
25         CFLAGS += -O2
26 endif
27
28 configure: configure-stamp
29 configure-stamp:
30         dh_testdir
31         CFLAGS="$(CFLAGS)" ./configure \
32                 --host=$(DEB_HOST_GNU_TYPE) \
33                 --build=$(DEB_BUILD_GNU_TYPE) \
34                 --prefix=/usr/sbin/ \
35                 --with-wwwdir=/usr/share/citadel-webcit \
36                 --with-localedir=/usr/share/ \
37                 --with-editordir=/usr/share/tinymce/www \
38                 --with-rundir=/var/run/citadel \
39                 --with-ical --with-db --with-ldap \
40                 --with-zlib --with-ssl --with-libiconf \
41                 --with-newt --with-included-gettext \
42                 --enable-debug $(EXTRA_ARGS) $(PROFILE_ARGS)
43
44         touch configure-stamp
45
46
47 build: build-stamp
48
49 build-stamp: configure-stamp 
50         dh_testdir
51
52 # Add here commands to compile the package.
53         $(MAKE)
54 #docbook-to-man debian/webcit.sgml > webcit.1
55
56         touch build-stamp
57
58 clean:
59         dh_testdir
60         dh_testroot
61         rm -f build-stamp configure-stamp
62
63 # Add here commands to clean up after the build process.
64         -$(MAKE) clean
65
66         dh_clean 
67
68 install: build
69         dh_testdir
70         dh_testroot
71         dh_clean -k 
72         dh_installdirs
73         $(MAKE) install-bin install-locale install-wwwdata DESTDIR=$(DESTDIR)
74 #       mkdir -p $(DESTDIR)/etc/citadel; cp webcit.conf $(DESTDIR)/etc/citadel/
75
76
77
78 # Build architecture-independent files here.
79 binary-indep: build install
80 # We have nothing to do by default.
81
82 # Build architecture-dependent files here.
83 binary-arch: build install
84         dh_testdir
85         dh_testroot
86 #       dh_installchangelogs ChangeLog
87         dh_installdocs
88         dh_installexamples
89         dh_install
90 #       dh_installmenu
91         dh_installdebconf       
92 #       dh_installlogrotate
93 #       dh_installemacsen
94 #       dh_installpam
95 #       dh_installmime
96         dh_installinit --name=webcit
97 #       dh_installcron
98 #       dh_installinfo
99         dh_installman
100         dh_link
101         dh_strip
102         dh_compress
103         dh_fixperms
104 #       dh_perl
105 #       dh_python
106 #       dh_makeshlibs
107         dh_installdeb
108         dh_shlibdeps
109         dh_gencontrol
110         dh_md5sums
111         dh_builddeb
112
113 binary: binary-indep binary-arch
114 .PHONY: build clean binary-indep binary-arch binary install configure